Balance One and Apple iPhone issue

Recently, we upgraded our environment from using a Surf SOHO to a Balance One router.

Ever since then (almost daily), there is an issue we’re facing with an iPhone SE and the Balance One router. The iPhone SE establishes a WiFi connection just fine to the router, but then at some point (sometimes 2 or 3 minutes,sometimes a few hours later), they stop exchanging data. The connection stays established though, which causes headaches with apps thinking they’re network connected.

When this happens, attempting to load any webpage fails, trying to retrieve email fails, trying to run applications relying on the internet fails, etc. This affects both connections from the iPhone to other machines directly wired to the Balance One, along with connections from the iPhone through the router to the internet.

The big hassle this creates is the phone keeps the connection established with the router. So anything trying to use the network now fails. The moment you disable WiFi on the phone, having it fall back to LTE, everything immediately works (granted, all intranet systems no longer are reachable).

The quick fix is to turn off WiFi and then enable WiFi on the iPhone. Then everything is reachable from the phone again. But this then either works for a couple of minutes or a couple of hours. It appears completely random.

I thought I had seen information in the Balance One Release Notes from an earlier firmware version that indicated compatibility issues between the Balance One and iOS had been improved.

Have you guys seen this before?

Thanks,
Niel

Hi Neil
Did you try and reset the Network Settings on the iPhone?
Try that, if you did not yet. Then do a hard reset of the iPhone.
You need to find out that process for your particular iPhone.

Let me give that a shot, thanks for the recommendation. The phone works fine at another family member’s residence (although they’re not using a peplink router). Will keep you posted.

Thanks.

Resetting the network settings on the phone and a reset of the iPhone unfortunately did not resolve the issue. I have moved the iPhone over to a Peplink Rugged AP and have not experienced the issue since. I’d still like to get this working on the Balance One, but current work projects will prevent me from having the time to diagnose it further at the moment. I’ll open a ticket in the near future on this.

Thanks again for the suggestions.

@Nielb,

Possible to open a support ticket to allow support team to check on the device.

1 Like

The iPhone puts its wifi connection to sleep to save battery. As far as I can tell it is not a user configurable setting. I learned this problem using softphone apps that would connect to our phone sever via wifi. When the wifi goes to sleep the phone connection was lost so the device does not respond to inbound calls.

As a test I suggest you program the iphone display so it never goes to sleep. I believe that also prevents the wifi from turning off. Or run an app such as continuous music download. Anything that forces the wifi to stay on.

I do not have this problem with Android phones.

2 Likes

The default AP settings on the Balance can cause sporadic connectivity issues with newer wifi clients, especially Apple products. The default beacon settings are optimized to include older 802.11b devices. Adjusting the beacon settings for modern wireless devices may resolve connectivity issues with Apple clients.

Go to AP > Settings > [AP Profile Name] > ?
Click on the indicated link to set advanced AP settings

  • AP Settings > Beacon Rate
    Change from 1 Mbps to 6 Mbps.
  • AP Settings > Beacon Interval
    Change from 100ms to 250ms.

Note that this will effectively prevent 802.11b client devices from connecting to the AP radio. Keep this in mind, especially if the AP is a public network where you don’t have control over the devices which will be potentially connecting.

To be certain – Apple devices seem to be more sensitive to beacon congestion than Window and Android clients. However Windows and Android clients can be affected as well.

@Nielb

Are you using auto channel on Balance One WiFi AP? If yes, could you please try to configure those 2.4GHz/5GHz channels to static channel and un-check the “Discover Nearby Networks”?

Please let us know if this can help your case.

Thanks,
Lewis

2 Likes

Hello and Good Day lewisbohn.
I tried those settings you mentioned above, and they won’t save…any clue as to why?

Thank You

These settings seem not to be available for IC2 configurations. Suggestions?

I don’t use IC2 for management, so I’m not sure if these settings are exposed to IC2.

You may be able to access them by drilling down to the device in your organization then:

  • Settings > Remote Web Admin > AP > Settings > [AP Profile Name] > ?

This may or may not be possible if IC2 is managing your Wifi settings

Even if you make the changes, IC2 may be immediately revert them if Wifi management remains enabled for IC2. You may need to disable WiFi management in Group-wide SSID Settings to ensure local configuration changes aren’t wiped out by IC2. However someone with more IC2 experience may be able to point out where these settings are exposed in IC2.

Background:
We’re using IC2 for device management, so tweaking an individual device is limited to whatever IC2 provides for.

Summary:
Configuring the Balance One WiFi with fixed channel selections seems to correct the problem for this deployment. An unsatisfactory, but workable solution.

Configuration:
For this particular exercise we employed

  • Balance One
  • 2 AP One Enterprise
  • 2.4 and 5 GHz both enabled on all devices

Base configuration:
Deployed

  • Balance One - WiFi enabled
  • 1 AP One Enterprise
  • Everything set to automatic configuration of the radios

Experience:
iOS devices connected through the Balance One would routinely lose connections if they were connected to a 5 GHz channel

Corrective action #1:
Deployed

  • Balance One - WiFi disabled
  • 2 AP One Enterprise (one of them replacing the WiFi functionality of the Balance One)
  • Everything set to automatic configuration of the radios

Experience:
iOS devices connected through the Balance One would no longer lose connections. All is well.
But the addition of an extra AP defeats the WiFi purpose of the Balance one.

Corrective action #2:
Deployed

  • Balance One - WiFi enabled (again)
  • 1 AP One Enterprise
  • Radio configuration of the Balance One: Fixed channels (set in IC2)

Experience:
iOS devices connected through the Balance One would no longer lose connections. All is well.
But the lack of automation in channel selection of the Balance One WiFi is unfortunate.

2 Likes