Balance 380 reboots automatically

Hello Everyone, We have a Peplink Balance 380 (H/W v5) running at our production environment. We have 3 WAN links (2 x 100Mbps and 1 x 50Mbps) connected via direct PPPOE through the SIPs Modem, Our average download usage is about 70-90Mbps only (our upload usage is less than 20Mbps). Theory this router suppose to support up to 200Mbps throughput. That was the reason for us to upgrade two of our links from 50Mbps to the current setup of 100Mbps which brings to my question here.

Few weeks after we did the above upgrade, once in a while, the device started rebooting itself automatically while showing high CPU usage (over 80%) almost all the time so we’ve assumed it might maxed out due to the bottleneck on throughput of the device due to the increase of the download speed.

As the reboots become more frequent we had tried disabling one of the 100Mbps lines completely and removing it form bandwidth aggregation (making the combined bandwidth as 150Mbps download) in an attempt to isolate the issue. Unfortunately it did not fix the issue. we tried further reducing the allowed bandwidth using the under Network>WAN>Connection Settings>Upload Bandwidth and Download Bandwidth down to 80Mbps on the 100Mbps connection but we are still going through the reboots every now and then with CPU is consistently above 90% during the peak times.

We are running the latest firmware and the device is used only for bandwidth aggregation only other than for some port forwarding settings configured for local servers. What I would like to know is, if there is a way for me to isolate the issue of what is causing the device to reboot. If it is the throughput is still being bridged or any other factor making this device to reboot on it’s own, I’d like to know a way (Eg: tool or interface) to find out so that we can plan our next step (Eg: Upgrade device).

Please try this firmware. If the problem persists, please help to download Diagnostic Report when you notice the CPU load is high. Then open ticket and submit the Diagnostic Report for us to investigate.


1 Like

Hi. Thanks for your reply. we did perform the said firmware upgrade but unfortunately, the issue stay same. I will log in a support case as requested. Thanks again.

1 Like

HI good day we have the same issue happening with no fix as yet.

Latest firmware 6.3.1 build 1631

For such issue, please open a support ticket for support team to check. The device reboot can be cause by a lot of influences. The influences can be cause by Environmental or other reason. It’s not easy to work here without checking from the device.

Beside that you mention that firmware version 6.3.1. This is a old firmware. You can download the latest firmware using the following URL:

1 Like