Balance 20X updated to 8.2....Now will not connect.

Updated 20x to 8.2 this past weekend. Let it run 48 hours and everything was working. Installed the SIM card for failover. Booted. NO connection either from main WAN or cellular.

Removed SIM card, rebooted, still NO connection.

Installed saved .conf with 8.2 No connection.

Installed saved .conf with the prior save to installing 8.2. No connection.

My next step is to reset to factory default and try from there.

This issue is similar to the no connection issue from July of last year that Rick, Mike, TK and several others helped on resulting in an upgrade to the firmware. I think I should have left well enough alone.

Last thought. Could I have shorted out the unit by installing the SIM card wrong? I don’t see how I could have but leave it to me to find the wrong way. Please excuse if this query is in the wrong category. The new forum set up is confusing to me.

Open a ticket.


Hi again Tom. Highly unlikely this issue was caused by installing the SIM card wrong. and, keeping FW up to date is encouraged – not discouraged. I agree with @erickufrin – it’s time for a ticket.


Thank you Eric & Rick.

Since I made this post I was able to restore the B20X to Firmware 8.1.3s072 build 5078 and the B20X is back up and running. The SIM card is NOT installed. I have not created a ticket.

My thought was to let the B20X run with the old .conf and on Saturday update the FW to the 8.2. As I said earlier, 8.2 was running about 48 hours before installing the SIM card. Further, my thought is to immediately create a download .conf of said update to I guess forward to someone at Peplink? And then create the “ticket” if the B20X does not connect again.
I’m trying to avoid having to connect the previous router, a Synology RT2600ac while Peplink helps me with a fix.

Tom: Is the 20X running OK with “wired” internet WAN? I can’t recall – are you using cellular only or both wired and cellular?

1 Like

@tws ,

You can open a ticket first with a device diagnostic report to allow Peplink support to review first. Definitely you can discuss with Peplink support for the best option to work on the issue. Please include this forum in the ticket so that support team aware the discussion here.

Appreciated your help on this


Excuse the slow responce. I had to revv up my iMac, it’s not as locked down as My Linux daily use machine’s browser is so locked down I am unable to reply using it. All of the “Reply Edit Delete Solution Flag” GUI’s listed at the bottom of a post are missing using Linux. Not on the Mac. Apparently each one is assoicated with analytics, tracking and other stuff I do not understand. I just don’t want that crap on my main Linux computer.

To answer you question;
Yes the 20X runs fine with Comcast wired. Comcast is the ISP and nothing else. I have my own 2.5gig modem and of course the 20X.
Right now, the sim card for the cellular side of the 20X is NOT installed.

I am still using Firmware 8.1.3s072 build 5078 from last years fix. The only issue right now is both iPads have an issue reconnecting to the wifi from sleep. But I’m pretty sure this is an Apple issue due to a recent update. Since updating to the old FW, I’ve had to delete the SSID’s I use from the network on the iPads, reintroduce and sign on again. AGAIN, I believe this is an Apple issue. NOT a Peplink issue.

Thank you for helping out.

Sit Loong See,
Hi sir. Also excuse the delayed responce. Please see explanation in reply to Rick DC. I will be glad to provide the info you or Peplink needs to help ID the concern.
Since I’ve got the 20X back up and running using the FW from last years fix via TK’s help all I can provide now is the first and only .conf I saved approximately 15 minutes after 8.2 loaded and the 20X was running. As stated in the original post, 8.2 ran about 48 hours before I attempted to install the sim card, upon installing the sim card and rebooting the 20X is when it went off-line. At that point I connected the old RT2600ac to maintain connectivity. I didn’t think then that perhaps saving the .conf again of the 20X NOT WORKING may have provided info so Peplink could analyze what happened. Sorry about that.

So as soon as I can get all of the chores done around the house today, I intend to follow up with the “ticket” a “device diag report” and include the forum. I guess a link to the original post will work.

I do appreciate your guidance.

1 Like

Updated the B20X again, this time to 8.2.1 as suggested by Soriam. It worked, system was running. Installed SIm card, rebooted. NOTHING. Saved and applied changes of course. Dashboard shows the Comcast WAN “connecting” as does the cellular. Neither ever connect.

Of course I can’t be without connectivity so the RT2600ac is back up and running for now till Soriam suggests the next step.

I think, for now this post in the forum can be closed. Best to all.