Balance 20X slow upload speeds

I have a new Balance 20X with minimal configuration (no VPN/SpeedFusion, default outbound policy, etc…) but the internet upload speed is much slower than the download speeds.

With a direct wired connection to my Gig fiber gateway, I can consistently achieve ~950 Mbps up and down with speedtest.net from my laptop

When I direct wire to my Balance 20X (which is then connected to my gateway) from the same laptop I can get ~850 Mbps down (expecting this since the max throughput listed for the Balance 20X is 900 Mbps) but only 90 - 100 Mbps for uploads. That’s total upload bandwidth so if I run a test on two devices at the same time the upload bandwidth is split/shared between them (I checked this in case it was limiting per device…).

While I don’t expect full Gig upstream, a 9 or 10 fold decrease seems excessive.

Anything I should check or has anyone else experienced this?

Thanks in advance

I only have 20 mbps upload but maybe check your WAN connection settings under Network > Wan and see what values are set for this:

image

I’m unsure whether this would actually impede your speeds or not, as they are used for traffic prioritization. But try changing these to your actual ISP values and see if that addresses the issue.

Thank you for that - I just checked and it’s at the default 1 Gbps up and down…

image

Just in case I set the upload bandwidth to 200 Mbps to see if that would make any difference but it’s still uploading in the 90 - 100 range…

Just a sidenote, the upload and download bandwidth options are used primarily for overflow outbound policy algorithm. Since the algorithm needs to know when a link is “saturated”, it compares the current usage against what you have configured here.

The bandwidth profiling (reservations/limits) also take these values into account.

My point is that this value will never limit throughput. i.e. If you put 10Mbps in there, you would still be able to get your 900 Mbps download.

1 Like

Enabling the Mitigate Bufferbloat option on the support page will limit the upload speed to the Upload Bandwidth value. This is the option which turns on the fq_codel algorithm for Upload, but not currently for Download. On my Balance, this was “http://192.168.xxx.1/cgi-bin/MANGA/support.cgi”. On the home page, I just change “index.cgi” to “support.cgi” in the url to reach this special option.

You can test your Bufferbloat grade/rating at http://www.dslreports.com/speedtest. If you are trying to improve your Bufferbloat rating, you generally set the Upload Bandwidth value to somewhere between 90-95% of your provisioned ISP speed (same for Download Bandwidth too whenever Peplink makes it operational). It has been my experience that asymmetric service where upload is much lower than download speeds generally benefits the most from fq_codel (certainly Comcast/Xfinity although FEC may be even more beneficial these days in many neighborhoods due to the prevalence of dropped packets on their often overloaded upload links). Please be aware that fq_codel has cpu overhead.

I assume you are getting the speed from the speed testing website. In addition, while running the speed test, also look at the real time bandwidth display in the router (Status tab -> Real Time).

You may be hitting the max speed of the speed testing website. So, try a few speed testing sites: fast.com, librespeed.org, speed.cloudflare.com, speedof.me and speakeasy.net/speedtest/

Without the Balance 20X in place, I get 900+ Mbps download and upload symmetrically from several of the speed testing site - it’s only when I put in back that the upload speed drops to 90 - 100 Mbps, so there’s something in the Balance 20X that’s limiting the uploads…

From the B20x documentation

DSL/Cable Optimization
DSL/cable-based WAN connections have lower upload bandwidth and higher download bandwidth.
When a DSL/cable circuit’s uplink is congested, the download bandwidth will be affected. Users will not be able to download data at full speed until the uplink becomes less congested. DSL/Cable Optimization can relieve such an issue. When it is enabled, the download speed will become less affected by the upload traffic. By default, this feature is enabled.

I can’t think of anything else and doesn’t seem like this would matter, but you never know if enabled by default there some kind of algorithm at play.

If that doesn’t work, maybe open a ticket with support?

@sulakand

Just performed a quick check using my B20X device for the best effort 400Mbps download and upload internet link and i don’t see the upload speeds issue.

Do you tested using other PC/Laptop ? Are are getting the same results ? If you see the issue for other devices, please open a ticket for support team to check. Look like this maybe a isolate case that support team may need to investigate from your device to confirm what influence the low upload Speeds.

Maybe the B20x thinks the upload speed is 100Mbps due to an Ethernet speed negotiation issue with the modem. Not saying that is the problem, but that would explain the speeds maxing out at 90 and 100Mbps. And we do know there are issues with modem negotiation on the B20x.

How can you tell if this is the case? Beats me.

1 Like

You are right @Michael234 , the 90-100Mbps is really suspicious for the link nego between the B20X and modem. The best is to test with other PC/laptop using other hardware chipset to confirm.

Thank you for confirming that with your setup; I’ve tested on 2 laptops (Thinkpad and Macbook) with the same results - full throughput both up and down (~1Gbps) direct wired to fiber gateway, but only ~90Mbps upload through the Balance - I’ll open up a support case.

BUT - I really love and appreciate the input on these forums - one of the big reasons I stick with Peplink products!

I agree with both of you, @Michael234 and @sitloongs - the 90 - 100 Mbps upload is suspiciously like a 100Mbit link, though the downstream throughput of ~900Mbps through the same connection and the 1Gig link reporting in the Balance 20X suggest otherwise… Just in case I swapped cables, different ports from the gateway to the Balance and anything else I could think of that falls into the “really shoudn’t affect it but just in case” category…

You have me convinced the router is the problem. Now the question is why?

The easiest thing to rule out is the changes you made to the configuration. Backup the system settings (twice for good luck) and do a factory reset. Then test with a default out-of-the-box configuration. This rules out any changes you may have made and makes it easy for Peplink to try and re-create. And, just doing the factory reset may fix the problem in and of itself. Its happened to me with a Chromebook.

Just for the record, what modem do you have? Can you log in to the modem and access any logs it may have?

Michael234’s suggestion of testing the B20X after a factory reset sounds like a great idea.

Have you had a chance to put another router in place of the B20X to see if it can get above 100MB upload (maybe you have an older Peplink)? If you can get above 90-100MB upload, that would certainly seem to clear the modem, your wiring, your laptops and further point the finger at the B20X.

If another router can exceed 100MB, then you may also want to try hooking up the B20X behind the other router (modem->other router->B20X->laptop) to see if you can still get above 100MB upload. Just make sure the B20X isn’t using the same subnet address as the other router so that the B20X ends up with a dynamically assigned WAN IP address which overlaps the subnet range that your laptop is using on the B20X. Otherwise you get into routing issues.

Curious if you are running your B20x on fw 8.0.2 or 8.1.0 ? Mine came out of the box with 8.0.2 installed.

To add to what @Michael234 mentioned, assuming your are running on fw 8.1.0, have you tried on fw 8.0.2 and experience same performance issues?

The idea of modem->Other Router -> Balance 20x is an excellent one @Mark9. If the problem is an Ethernet speed negotiation issue, this could avoid it. That said, I might start simpler, with a dumb switch between the modem and the B20x. Still, the idea is a great one.

Again - thanks to everyone for the input. I did open up a ticket with peplink support and they are researching, though @stego’s idea of rebooting to previous firmware sounded great (and an easy switch to make) which resulted in:

When I rebooted back to firmware 8.0.2 build 1045, the speed tests reported:
~650 Mbps download / ~400 Mbps upload (slower download speed but much faster uploads)

I then rebooted back to firmware 8.1.0 build 4938 and the speed tests reported:
~900 Mbps download / ~90 Mbps upload (same as before)

So it looks like this is software related…

1 Like