Balance 20X slow upload speeds

Thanks @TK_Liew , I’ve opened ticket #20101007 for this.

1 Like

Same experience here - I am on a 500 mbps down & up FTTP connection. On a Balance 20X, after upgrading to firmware 8.1.0s024 build 4951, Speedtest results came in at ~500 mbps down and ~90 mbps up. After re-booting back to FW 8.0.2 build 1045, results are back to ~500 mbps for both down and up.

@winchesterv, please open a ticket for us to check.

BTW, we just did a quick test with firmware 8.0.2 vs 8.1.0 on the B20X, with the same DHCP WAN + iPad as the client + server. It looks like the upload/download performance doesn’t vary much.

  1. Firmware 8.0.2GA

  2. Firmware 8.1.0GA

1 Like

So after working with Peplink support for a few weeks, running tests and trying special builds - I believe it was determined that a driver for the B20x embedded in the 8.1.0 firmware was limiting the upload speeds. I’m now running the 8.1.1. RC1 build 4979 and am able to get ~900 Mbps down and ~700 Mbps up through my Gig fiber connection.

Thank you Peplink support!


Thanks–Use of 8.1.1. RC1 build 4979 has resolved the issue with slow upload speeds on Balance 20X.

1 Like

Tested: Balance 20X Firmware: 8.1.1b02 build 4974

I ran an internal test. B20x WAN is hooked to a Surf SOHO LAN port. Copied a 15GB file from a computer behind the B20x to an SSD NAS box connected to the Surf SOHO. As shown here, upload averaged 787Mbps. It could have probably gone faster, the Surf SOHO was at 100% cpu during the file copy.

On earlier versions of firmware 8, I had noticed that during this file copy (I do it often) the speed started fast, then slowed down to 100Mbps or so. I thought it was a clearly fraying Ethernet cable, which is connected to the source machine, so I did not investigate.

1 Like

Hi, I am new to peplink (coming from netgears now crappy R7000 nighthawk router). I have never heard of bufferbloat before but decided to test mine out. i went to the dslreports website and did a test. got an A+ for “overall” and “quality” but the “bufferbloat” and “speed” ratings were not available. Does this mean my connection or config has issues?

When it was a negotiation issue, it would not differentiate between upload or download. It would negotiate to FE (both ways)… Or am I wrong?

This test is interesting! Do you maybe have such a test through the tunnel, with bonding enabled? Sorry for mixing a little bit the theme, but I am new to PL and I am looking for Balance 20X throughput tests (with and without tunnel usage). Thanks!

Sometimes a “bufferbloat” rating doesn’t show up if the results are very poor. Or, if my memory serves (from travels to remote islands), you are selecting something like “Satellite” rather than “Cable” or “DSL” for your test. I’ve never seen your combination of results however.

When you get your results, you are able to select “Results + Share”. That will create a test number. I am happy to review the results if you want to provide the test number as a reply to the forum, or as a message to me. For example, Speed result of 329.3/9.17 Mbps | DSLReports, ISP Information.

heres the speed test. the download speed is pretty high for what i have (300Mbps with an often 20% extra so 360Mpbs)

i just did another after setting up an account so i can track it. didnt realize the speed grade doesnt come up unless i have an account setup with my speeds programmed in. still no bufferbloat rating though

I have not used a VPN on my Balance 20x.

I am able to get Bufferbloat results without being a member, as are many others. Do you actually see the Bufferbloat guage when running the test but just don’t get a grade? If so, you will see the dynamic Bufferbloat behavior.

I did notice that your Round Trip Times in the Server section near the bottom have some high values, 107ms. I am assuming that you have a PC directly connected via Ethernet to the Peplink, rather than using WiFi. If not, please try the test directly connected.

An alternative to Speed test - how fast is your internet? | DSLReports, ISP Information is which shows Unloaded and Loaded Latency (“Show more info”), with the difference between the two being an indication of your bufferbloat. The latency figures by default are for download only. In Settings, you can select “Measure loaded latency during upload” which dynamically updates Loaded Latency values. Dslreports grades the delta latency increase as “Less than 5ms (average of down bloat and up bloat) - A+, Less than 30ms - A, Less than 60ms - B, Less than 200ms - C, Less than 400ms - D, 400ms+ - F”

Or you can run other speed tests while running a ping to see if the ping times vary under download and upload as is explained in Tests for Bufferbloat -

1 Like

About 4 years later and I am experiencing the same issue with my Spectrum fiber internet where the spoed is cut down significantly from 600Mbps on primary router down to 30Mbps down when connected to Peplink b one. Upload speed seems normal. Alternative wan 2 seems ok too as it’s speed is around 50 up and 6 down. I have had my ticket open for a month for various issues but this one is the biggest concern.

I am not sure from your description whether you replace the Spectrum primary router with your B One, or you hook up the B One to the Spectrum router. Please clarify. I will assume the latter, and will also assume that you have nothing else hooked up to the Spectrum router other than the B One via an ethernet cable, and that Wi-Fi is disabled on the Spectrum router (for two reasons; not interfering with the B One Wi-Fi and making sure everything goes through the B One, especially if you are attempting to control bufferbloat in the B One). I don’t know if you are doing double NAT or not with the two routers, but that should have no bearing on your speed issue (most people try to eliminate double NAT by bridging the Spectrum router in some manner, but it seldom presents much of an issue unless you are doing something like port forwarding).

What happens when you hook up a PC to the same cable that is currently plugged into the B One and run the speed test? Cables can be bad, so you should always try different ones for everything in your testing path. And testing with a hardwired PC would also help support the case of the issue being centered in the B One. (I am assuming that everything else is unhooked from the B One and Spectrum router when testing.)

You may also want to consider plugging the Spectrum ethernet cable into WAN 2 to see what happens (this may require some reconfiguration if the WAN’s aren’t DHCP). This would eliminate the B One having a bad WAN 1 port.

I am guessing that you are using Mitigate Bufferbloat on the B One. If so, what happens to your speed when you disable it? And for the record, what are Upload Bandwidth and Download Bandwidth settings, and do you have DSL/Cable Optimization enabled or disabled?

I would also recommend observing the Peplink B One cpu utilization when running a speed test to verify you aren’t running into a CPU speed limit. You shouldn’t be.

I currently depend on Waveform bufferbloat test instead of Speed test - how fast is your internet? | DSLReports, ISP Information as are many people (I have issues with dslreports not working that I haven’t been able to solve in the 10 minutes I have spent trying).

I swapped wan1 and wan2 with same results. Connected directly to b one with ethenet with same result. Correct Spectrum ONT is only connected to b one and nothing else as it is just a modem and not a router. Its internal workings are not accessible to customers. Verizon home lte works normal speeds but not spectrum fiber. Ports have been set to auto or 1Gbps with same results. B One was reset to factory defaults as of yesterday with same result. Initially speed will be over 400Mbps with various ookla speed locations nearby and them drop to 30 - 100Mbps down after 5 minutes. Now if I put spectrum back on my primary netgear router it goes to 600Mbps and if I disconnect and put it back on priority 1 wan on b one with it connected back to netgear, it measures 30Mbps down. It would be great if ai could use the peplink with its intended purpose of dual wan with full provider speed providing all sorts of benefits feeding my netgear and its satellites for internet since my devices are spread behind the reach of the wifi the peplink b provides. Hopefully they can find a solution.

So lets see if I understand correctly. The B One drops down to 30-100Mbps from 400Mbps in two scenarios; directly connected to the ONT and connected to the Netgear which is connected to the Ont.

In the latter case with ONT->Netgear->B One, what happens when you run a PC test when directly connected by Ethernet to the Netgear while the B One is still connected to the Netgear but nothing happening on the B One? And then running a simultaneous speed test (if you can) from both a PC connected to the Netgear and another PC connected to the B One?

I receive full speed when connected ONT is connected to netgear wan as measured through its app interface. Same when connected directly with pc. Now, I do not measure speed for peplink when spectrum is on the netgear wan as peplink is not connected as otherwise it gets confused on the lan side and assigns itself the network. The problem occurs with spectrum higher speed connection on wan as Verizon connection appears to perform fine. That is correct, 400 down when connected for a few minutes and it drops shortly thereafter below 100 and then to 30Mbps. I do not recall seeing a cpu usage measurement on the device but latency for spectrum is over 5 times of what is normally, 60 ms versus like 8 ms using wan analysis and around normal it appears for Verizon around 50 ms.

You should be able to find CPU utilization on the main B One dashboard when you log into the web interface as this is a feature of every Peplink router that I have used (I haven’t used the B One yet). So it would be great if you observe it when running a speed test through the B One WAN connected to the Netgear LAN from your hardwired PC (doing this test bypasses funky things possibly happening between the ONT and the B One). Look for the Device Information box with “CPU Load” which shows a green line for CPU % (red when you get to high loads).

Testing with the B One hooked up to the LAN ports of your Netgear is a useful test. You are probably running into the fact that the LAN subnet for any router can’t overlap its WAN address. So if the Netgear assigns a DHCP IP address of to the B One for example, then the LAN subnet on the B One cannot be since they overlap. So you change the DHCP subnet settings on the B One to something like Or possibly the B One is smart enough to change it to something else for you. I would change the DHCP subnet settings on the B One manually, at least for the duration of your testing.

Latency of 60ms under load when testing Spectrum actually isn’t horrible. It could be better. But at least it isn’t reaching hundreds of milliseconds or seconds. That may change however if you ever get the B One to run higher download speeds.