WiFi through Max Transit Duo significantly slower

Hey all, we’re at an RV park with really good Wifi (above 90mbs down). When connected through the Duo I’m seeing speeds of 13-18mbs down with only that WiFi running and even slower when I combine WiFi and Verizon cards. I have a far better connection just going directly on the park WiFi, which defeats the purpose of getting the Duo. Firmware is up today and I even stripped down all of the Outbound policies so it’s 10 all the way down. I don’t know what else to do to get better speeds. Thanks, Mike

What device were you using to connect directly to the campsite wifi with when you got 90Mbps?
When you connected using the transit which wifi wan radio did you connect with? what did you then use to test the transit wifi with?

How are you doing this? SpeedFusion Cloud? Your Own Fusionhub? Or is is load balancing only? How are you measuring the speed?

1 Like

Hey Martin, so I’ve trouble shot some more. The device I am using is my work laptop connected via WiFi and tested on both 2.4 and 5ghz with the same results, 13-18 down and when I connect my laptop directly to the park WiFi I’m getting close or over 100 down. When I connect my laptop directly to the LAN I’m getting the park WiFi speeds so somehow the Duo is grabbing the WiFi, but only giving us a portion of the speeds. Right now, I went back to basic out of the box with only the default Outbound policies with everything at 10 and no speedfusion. Another person said I should buy the AP One AC mini to get faster speeds. My Duo is only 2 months old, I don’t understand why I’d need to buy another PepLink product to get speeds I should get right out of the box right?

Hello Mike,
What version of Firmware is your MAX Transit on? Are you on 8.1.1 GA?

When using the Wi-Fi WAN, the 2.4Ghz & 5Ghz are sharing the same radio hardware.

Here is a suggestion, on your MAX Transit web admin dashboard, attempt using just one of the 2.4Ghz or 5Ghz radios at a time and use the opposite radio to supply the Wi-Fi AP, capture your results and share the difference (share the images of the dashboard and WAP setting so the community can verify them for you). You may find (and it can vary per location) that choosing just one radio band to connect to the public Wi-Fi will be better.

These are the variations you can test

Variation # Wi-Fi WAN Wi-Fi AP
1 2.4 GHz 2.4 GHz
2 2.4 GHz 5 GHz
3 2.4 GHz 2.4 GHz & 5 GHz
4 5 GHz 2.4 GHz & 5 GHz
5 5 GHz 5 GHz
6 5 GHz 2.4 GHz
7 2.4 GHz & 5 GHz 2.4 GHz
8 2.4 GHz & 5 GHz 5 GHz
9 2.4 GHz & 5 GHz 2.4 GHz & 5 GHz

There is a substantial community of RV users here in the forum that may have some helpful ideas for you also.

Happy to Help,
Marcus :slight_smile:


If you’re in an RV you likely have the Max T Duo WAN port available. Why don’t you use it to connect/wire a Mikrotik Bullet? This is what I use and it completely offloads the job of managing incoming radio signals from the Max (i.e., no WiFi as WAN) so that it can only manage your internal wifi. Keep in mind that the Max Transit CPU is wimpy so having even 500Mps signal available will likely only give you 65Mps or so at the router IF you’re using Speedfusion or a Fusionhub instance.

Hey Marcus,
On the Duo I have 3 WiFi’s 1 is 2.4GHz and its set for both 2.4GHz and 5 GHz with 5GHz being preferred. I just changed the 5GHz to also accept 2.4GHz with 5GH preferred. The last one is for guests and it’s at 2.4. Someone suggested I try using the same park WiFi and connecting them both which is working and I can’t believe I didn’t think about it before. So I have a better signal, but still significantly slower than when wired into the router.

Hey Joel, yes in an RV and have a WAN port open. I tried searching Mikrotik Bullet and couldn’t find anything. I found an article comparing the bullet to the groove so I looked up groove, is this what you’re talking about? MikroTik Routers and Wireless - Products: Groove 52

So sorry Mike. Ubiquiti has the Bullet. Mikrotik has the Metal 52ac that I have. The Metal is more capable than the Groove. You can read the specs. The Bullet also is limited.

Thanks Joel! I’m currently on a 5 month trip and not in a position to add anything externally at this point. I just ordered a wireless access point to see if that’s the issue, if it isn’t I’ll send it back.

Yes. You can turn the router AP off and use an external AP off of the lan port but I’m not sure this will reduce the load on the CPU. I use external APs as well.