WiFi Drops Daily - how to troubleshoot, any logs, etc

Pepwave Surf SOHO MK3 8.0.0 build 1429

Several times daily, my WiFi drops for 1-3 minutes. The wired connection still works. I have seen several discussions on the forum about various solutions - WAN, looking at other devices, interference, etc. I have moved the device to another part of the house and the problem persists. I looked for conflicting AP nearby, etc. and don’t see an obvious problem. This has been going on for a while, now it is affecting me more as I work from home! I looked in the Event Log and there is no indication of a problem there at the time the WiFi dropped.

5 VLANs and 4 SSIDs configured. 20 Wireless clients max. 1 wired connection.

My questions:

  • Are there logs on the SOHO device that might shed some light on the issue?
  • Where are they?
  • How would I access the logs?
  • Any other thoughts?


Not to sure about the logs but you should probably update the firmware.

Additional thoughts:

Mine started crashing recently. I suspect I had too many wireless networks and VLANs configured. I deleted a few of them and everything has been solid. 5 VLANs and 4 SSIDs should be okay.

Also 2.4Ghz is usually congested so I switched to 5Ghz. I have seen IoT and home routers malfunction and cause interference. Most of that happens on 2.4Ghz.

More stuff:

I recommend making separate 2.4Ghz and 5Ghz wireless networks to isolate clients - and hopefully the problem.

5Ghz for clients that are closer to the router. 2.4Ghz for clients that are further away. When the WiFi gets interrupted, are both frequencies affected?

One trick(?) I learned to monitor my connectivity is to stream an internet radio station like KABL for example. If the audio stops - you have an interruption so you can immediately audit the SOHO client list etc. to see what’s going on. Or if you have multiple users streaming etc. they would let you know right away I’m sure.

Move important computers or anything you can to a wired connection to free up the radios / airspace.

Remember 5Ghz 802.11ac has more capacity than 2.4Ghz and a more sophisticated management algorithm for juggling clients and interference. Move high demand clients to 5Ghz. As a rough guideline: 2.4Ghz = 200Mbps and 5Ghz ac = 500Mbps of useable throughput.

A WiFi monitoring tool like inSSIDer can also help diagnose what’s going on. Keep that running to see what’s going on. The scrolling chart display will show you if your WiFi is shutting down.

I have this issue too, and i have not added any extra wifi networks or changed any settings besides content filtering.

Further, starting today the entire internet goes down and stops working altogether every couple of minutes, even on my wired connection. Now, there’s a possibility it’s just our ISP who is having issues, but I’m starting to doubt that because the internet has come back a few minutes after i rebooted the router.

But problems like these don’t seem to be all that uncommon with the surf sohos. I don’t think I’m ever buying a peplink router again. More trouble than it’s worth, especially since it doesn’t have some important firmware features (as they lock those down to higher end models… despite the price of this model being $200)

You may not have changed anything - but I bet your neighborhood’s total available WiFi bandwidth has now that everyone is working from home/quarantined. I moved everything to 5Ghz 802.11ac and have had no problems. The SURF even allows users to select completely unused 5Ghz channels to completely avoid all interference issues. I’m also looking for a good back up router or the next big thing -hopefully peplink releases a “SOHO MK4” soon.


This is why I don’t use 2.4Ghz anymore…

Similarly my Bluetooth speaker loses its connection 1-2 a day for the same reason. Buying a new one with adaptive frequency mapping didn’t fix the underlying problem and it still disconnects - but now I have 2 really nice Bluetooth speakers.

Change your Wifi frequencies from Auto to a specific frequency you choose. I’ve seen that fix this particular problem.

It’s already on auto for me. No dice.

My comment is about the wifi drop outs that DavidE the original post is having. Changing the wifi channel away from Auto, and selecting a fixed channel solved that problem for me.

Lzaic, who is your ISP? I ask because I often have trouble with Comcast not reliably responding to DNS health checks on their name servers. By changing the DNS server to, I have been able to fix that problem. Its not specific to Peplink. It seems some DNS servers don’t like constantly being asked the same DNS request. Can’t say for sure thats your problem but it won’t hurt anything to try.

This has happened to me this morning twice. iPhone dropped out then my laptop. Currently outputting syslogs to an ubuntu server but nothing in the logs.

This points to potential interference from nearby wifi networks.

Ran a network scan, and sure enough, my next door neighbor’s 5ghz band is running on the same channel as mine, (both running on ch 44) and his signal strength is stronger!

I run my mainLan wifi on 5ghz only. iOT vlan and guest wifi use 2.4 only.

I do have the surf soho on auto channel selection, I figured setting it to fixed channel would probably increase chance of conflict, since the router can’t adjust accordingly. That said, the router only checks a couple of times a day for channel conflicts… curious to know if there are better ways to configure the following:

My channel list to pick from is set to:

Screenshot from 2020-04-01 09-22-56
For now, switched to ch 157 and reduced channel width to 20mhz. Seeing about a 10mbps reduction in speed, but still getting a solid 50-60 mbps.

I am having a similiar problem. Pepwave Surf SOHO MK3 8.1.0 firmware.
While mine is the 2.4gh loosing connectivity / authentication. When it happens all the Echo’s will let me know and my wifi analyzer indicates a 2.4ghz signal is being broadcasted. Hard for me to see a pattern, this is my second warranty unit (refurb). While this never happened in the previous 6 months on original unit , my refurb unit has had two firmware updates.
My 5ghz and ethernet stays active, while all 2.4ghz shows a signal the devices on both vlans disconnect. I’m still adjusting settings but may put an ethernet/ap in play as a possible solution.
Still considering opening a ticket and sending in device report for analysis.

Your best bet is to open a ticket at this point.

I’m now running fw 8.1.0s058 build 4954 on a Balance 20x to address this issue specifically.

It was running fine for a few days then again all wifi drops and DHCP no longer handing out IPs.

Support has remote logging enabled to try and trap the next event, since they couldnt see anything in the diagnostic report i uploaded right after i came back online.

I have an Ubuntu server running on my network where i enabled syslog, so I point all my logs from the B20x there and it gives many more logs to look at. Seems to capture more than what the Router Utility will show you or even the event log view in the web admin console.