Wifi connection and signal issues on Max BR1 Mini

Hey guys! :wave:

I recently picked up a Peplink Max BR1 Mini. Updated firmware to the latest, so should be good there.

My symptom is that when I try to connect to the Wi-Fi of the unit, many times I get an authentication error and unable to connect. This could be from my Samsung phone or my Mac laptop. Sometimes the Wi-Fi won’t even show up as something to connect to.

I can literally be sitting 2 ft from the unit and have connection issues. Other times it works fine. If I connect using an ethernet cable it works like a champ.

The stereo in my RV (school bus conversion), don’t see the access point to connect to… But the stereo we’ll see the access point coming from Starbucks across the street. Which makes me think that the antenna itself is probably having a problem…

Has anyone dealt with this before?
Anything that I should be aware of, before I buy a replacement Wi-Fi antenna on Amazon?
Is there anything software related that this could be from?

I’m assuming that I could buy any old 2.4 GHz Wi-Fi antenna on Amazon. Perhaps ones with a higher DB of gain?


Hi @wallcrawler78. A higher gain antenna will not help and the OEM antenna is a pretty simple device and I think it is highly unlikely there is an issue with it.

Two questions before we go to the next step: (1) Do you have wi-fi-as-WAN enabled? (2) Firmware version?


As @Rick-DC says, the antenna is simple and unlikely to be the issue. However, I’ve made this mistake … do you have the WiFi antenna on the WiFi connection not the GPS? I now keep a red plastic cover on the GPS connection cos I’ve done it more than once!!!


1 Like

Thank you for the help!

Under wan quality monitoring it is set to “auto”. If I change the setting to custom I can choose from: wan, cellular, Wi-Fi wan. Is there a best option?

Firmware is 8.1.1

Sorry for my delay in responding, I wasn’t with my bus for a while…


Ha! Yeah wish that was the issue… it would be sooooo much easier to fix. Double checked it… Its correct

Hi Dan. You can leave the “WAN Quality Monitoring” as it is for now.
Back to my other Q: Are you using Wi-fi as WAN? If so, disable it. Any difference?

Where do I find this option? I don’t see it. I’m sure it’s sitting right in front of me just like milk in the refrigerator, with all of the different options and screens and tabs… I didn’t see anything.

Hi Daniel. OK, if you don’t have the MAX-BR1-MINI-LC-FS license installed you won’t see that option. (Sorry – forgot you have a Mini.) If that situation persists it might be good to submit a ticket.