Why is no firmware upgrade being shown?


#1

I am puzzled as to why my Peplink Balance 20 has not seen any firmware version higher than 5.2.2. I had seen reports of 5.3.7, and then when reviewing the forums again today see a reference to 5.3.8. Clicking the “Check Again” link in the GUI results in nothing showing up. Here’s what it looks like both before, and after:

    https://img.skitch.com/20110823-tx5rqyxpahqktry53xhgmj9ffy.png

I don’t recall the version number now that my new unit shipped with, but when I first installed the unit I was shown an update and applied it directly from the unit. That’s what got me to 5.2.2.

I can manually download 5.3.8, which I just did, but what is happening that is preventing the unit itself from seeing the upgrade(s) availability?


#2

I am experiencing a similar issue with my new Peplink Balance 30. It shipped with 5.1.5. After I installed it, Check Again showed 5.2.2 as available, I did a Check Again Firmware Upgrade, which successfully rebooted to 5.2.2. I have registered the device. The Check Again link shows 5.2.2 as the latest available, but the device management section in my online account shows 5.3.8 is available. I tried a Manual Firmware Upgrade to 5.3.8. It appeared to be successful, however, the device did not boot to it. Now 5.3.8 shows as available and non-running in the Reboot System GUI, but when I try to reboot to it, the device continues to reboot in 5.2.2. No errors or warnings during the process; repeated several times with the same result. So two problems: device not seeing the upgrade availability and device not rebooting to the manually installed upgrade.


#3

The firmware 5.3.8 for Balance 30, while released on the website, is not being released to the firmware upgrade system. This is part of our firmware release procedure and your devices are functioning properly.

As for Bob, can you report your upgrade problem to our support team at the following address?

http://www.peplink.com/contact/support/

Thank you.


#4

Matthew, you have left me more confused than I was when I first posted.

Can you please explain the “firmware upgrade system” and the “firmware release procedure”, and why it would not show what would appear to be major upgrades? Your phrase of “…is not being released to the…” is very worrisome. Are we supposed to infer from that statement that somehow these later firmware releases are not approved for the device, we should not be attempting to upgrade and if so, why is that? Certainly the option on the device to check for updates is there for a reason, and hopefully it would be to let the customer have quick and easy access to software they are entitled to use. This is after all, a registered device!

My unit is just over 30 days old, so if it is not supposed to run your later firmware I will return it for a refund. I was assured by the Peplink sales staff that the Balance 20 was a current product and would be receiving software upgrades for quite some time to come.


#5

Hi Marty, please let me explain this.

We have identified some last-min issues (in rare cases) with firmware 5.3.7 on some platforms. We decided not to put them on the auto update server (this is where your Balance device will check against for newer firmwares.)

Please be assured that your Balance 20 is fully supported and a newer firmware (5.3.8) is just around the corner. It is now under final testing by our labs, partners and the Beta team. (Note: For enthusiasts, we have a beta program which you can get access to the latest, greatest and bleeding-edge firmwares. Details at http://www.peplink.com/index.php?view=faq&id=43&path=16 )

We apologize for the miscommunication.

Hi Bob, I think you ran into an issue. Please try to re-perform the firmware update and see if it works. Please report your findings to our technical support team. http://www.peplink.com/contact/support/

Thank you.