WAN2 (StarLink) won't provide more than 500 kbps despite having 100 mbps+ (balance two)

Our StarLink ethernet adapter arrived yesterday and I excitedly plugged it in to WAN2 on my Peplink Balance2. WAN1 is CenturyLink DSL, providing 30-40 mbps down and 2-5 mbps up. WAN2 had previously been Viasat. I had always assumed that the horrible < 1mbps speeds I saw there were the fault of Viasat. However, when I plugged in StarLink, it does not achieve anywhere near the correct speeds.

If I connect to the StarLink wifi I see 100mbps+. If I plug the StarLink ethernet into my computer, I see the same. If I plug the StarLink ethernet into PepLink, not once have I ever even gotten 1 mbps.

I’ve tried the following:

  • Upgrading Peplink (Balance Two) Firmware to latest
  • Putting StarLink in bridge mode
  • Turning off DSL (making StarLink the only primary)
  • Changing the upload/download bandwidth settings
  • Changing the MTU (it auto-detects at 1500, but I tried 1492 to match CenturyLink)
  • Configured Dish Management

I’ve attached a pic of the WAN2 settings. What else could I be missing?

I finally tried swapping the two WAN ports, putting StarLink on WAN1 and CenturyLink on WAN2. Of course I had to completely reconfigure both ports, switching DHCP & PPPoE.

Now StarLink is getting the correct speeds on WAN1, but CenturyLink can’t even get to 1 mbps on WAN2.

Strangely, I notice WAN2 always gets random disconnect failures. Both PING and DNS based failure detections trip every couple minutes, both for StarLink and CenturyLink.

Both WAN1 and WAN2 ports are detecting 1Gbps full duplex.

I do not have any QoS set.

If I were you I would open a ticket. Sure seems like a defective device to me…

One piece of data which you could view to help confirm the issue is the support page.


Then click LAN/WAN stats… how do the stats and status look?

@inzania, that sounds like a hardware related as mentioned by @erickufrin, you may submit a ticket for the team to diagnose the device and determine the next step.

Just curious – did you do a hardware swap or was there another resolution to the issue?

Your Upload Bandwidth is set to 20kbps - most likely your issue


Good eyes!