WAN failed DNS test


#1

We’ve been using a Peplink Balance 20 with a single WAN connection for the past year. 5 weeks ago we added a wireless modem for backup

The Primary WAN is Time-Warner Roadrunner cable with a static IP. Time-Warner replaced the cable modem a couple of months ago.

Our local client software uses an SQL OBDC connection with our hosted business software (running on a dedicated server in a local data center). If we lose connectivity, it causes the software to glitch and we have to close and reopen the software far too frequently (we are looking at Citrix XenApp to eliminate this issue).

Over the past 2-3 weeks, we’ve been experiencing sporadic ‘WAN failed DNS test’ drops on our Primary WAN connection (Roadrunner cable). I’ve tried all the usual powering down and restarting of the cable modem and router.

According to Time-Warner they are not showing any issues with our connection to them, and they have not received any reports of issues with their DNS servers.

Initially I suspected the wireless modem. But after trying numerous settings - and most recently disabling the wireless, it appears the issue is elsewhere.

I’ve tried using different DNS servers, but I get similar results.

I have tried changing the Health Check parameters:
Timeout from 5 to 10 seconds and back to 5 seconds
Health Check Interval to 20 seconds
Health Retries to 5
I have also checked the Include Public DNS Servers box

Today I downloaded the latest firmware:
5.4.1 build 1439

I’m still getting the same issue…

Here is a sample of the error messages (I’ve edited the IP address). The timing is nearly always the same - the connection drops, then 60 seconds later it’s fine.
Jul 8 20:03:48 WAN: Mobile Internet standby
Jul 8 20:03:48 WAN: RoadRunner connected (24.213.xxx.xxx)
Jul 8 20:02:59 WAN: Mobile Internet connected to Verizon Wireless (10.182.xxx.xxx)
Jul 8 20:02:59 WAN: RoadRunner disconnected (WAN failed DNS test)

Most recently I started testing from home coming in through the router via RDP - and clearly the connection is dropping periodically as several times the connection has dropped or I could not get in - then when I check the log it shows a corresponding outage.

At this point I suspect the cable modem or the time warner service - but could this be an issue within the Router?

We have Time Warner due tomorrow to run more diagnostics - but if they don’t find anything, I’d appreciate any thoughts or suggestions on where the problem may be hiding.
**
Related to this, how can I configure the wireless modem to stay permanently connected, but not used unless the Primary WAN drops?** Because of the 3G performance, I don’t want any traffic using the wireless modem unless absolutely necessary.

Thanks, Jeff


#2

Thanks Jeff. Anything from the Time Warner diagnoses? It does sounds like there is some issue with the new Time-Warner modem.

And to have your 3G connected as a hot backup, we can simply 1) choose “Always-on” as connection method for Verizon Wireless to keep it connected all the time, and 2) under Network > Outbound Policy change the default outbound algorithm to Priority with Roadrunner cable as #1 and Verizon Wireless at second place.

Hope this helps. Thanks.


#3

Hi Kurt, Time Warner did find a couple of poor connections on their cable - the tech suspects that was the issue. I won’t know for sure for a few days until we see extended uninterrupted up time - so far so good - we’ve had a couple of hours without any drops. The tech ran a dropped packet test and didn’t see any drops after 10 minutes of testing - so he was fairly happy with the result. One of those bad connections was replaced at the same time the modem was swapped out.

I’ll make some changes in off hours and test the wireless connection with the changes you suggest.

BTW, when I used the router Web Admin software to check for firmware updates, it was showing we were current at 5.3.12. Only when I logged on to peplink and looked at downloads did I find the latest version 5.4.1. Shouldn’t the router be advising an upgrade was available? 5.4.1 contains some nice administrative enhancements - so it’s a worthwhile upgrade.


#4

Thanks for your update, Jeff. Feel free to let us know if anything else comes up then.

At the moment new firmware are announced through newsletter and on our website but we will take a closer look at push notification too. Thanks.


#5

Just to close out this thread, after 2+ days we’ve not seen a single drop on the cable connection. It turned out to such a simple thing - the coax connector on the end of the cable. The inner copper wire apparently pulled back into the cable and wasn’t providing a solid connection.


#6

Thanks for you update Jeff. Glad to know that everything is working well for you. Enjoy your Peplink :slight_smile:


#7

Hello,
While the post about the WAN failed DNS test by ​Jeffery Saunders post: WAN failed DNS test is old, the identical issues are happening to us right now.

We are a school with a Peplink Balance 580 Current firmware version: 5.4.9​, which is supposedly the latest update.

Since getting new modems from Time Warner Cable, our Internet has been going up and down with the “WAN failed DNS test” as the error message and then a few minutes later it comes back up again.

Tomorrow TWC is dispatching a technician to work with an engineer to figure out the problem. I saw at the end of Jeffery’s post that the problem turned out to be the coax connector on the end of the cable. I will point that out to the technician as soon as he arrives.

Just thought I’d post this to say that today is January 27, 2014 and this exact problem is happening to us.

Ellen


#8

Hello,

Thank you for the update. Certainly let us know the results if their is no issue on TWC side. Otherwise here is a example configuration you can test using Googles DNS.



#9

Jarid,
I don’t understand what you mean. Here’s what I could find. I believe our IPs are static rather than DHCP:


Ellen


#10

Hi sir, Same problem here WAN FAILED DNS TEST PEPLINK BALANCE 380… any advice? i upgrade FIRMWARE v5.3.12 build 1859 to v5.4.9 build 2573 the same issue. I move to SYSTEM>ADMIN SECURITY>admin setting > Web admin Access> i choose the LAN/WAN. its the same issue bro… the WAN1 is static IP and Second WAN is DHCP… THE PEPLINK Balance 380 must be Replace or What? u know how much this PEPLINK to replace is $2,499.00 bro? any advice PEPLINK Company? thank you…


#11


Here bro the Image


#12

Hi Glenfox, your issue is more on the WAN health check setting for your Balance 380. Balance 380 will use the provided health check server to verify the WAN availability. You need to make sure the health check server that you have configured are reliable and always reachable to avoid any false alarm for the WAN availability. Do you might to share your Balance 380 WAN health check setting here ?

WAN health check setting can be find here:
Network --> Interfaces --> WAN --> Choose available WAN and check on the “Health Check settings”

If you think inconvenience to share your configuration here, you may open a support ticket using the following URL with Peplink Support and they will help you to diagnose your issue
https://cs.peplink.com/contact/support


#13

I have had the same issue. I finally decided to treat the WFR as any other router, and I bounced it. Problem solved. Hope this helps someone. I imagine that the people who posted above probably tried this and it did not work for them. I just wanted to let people know that sometimes it does work.