WAN failed DNS test - disconnecting and reconnecting


#1

I have a Peplink Balance One Core running firmware version 7.0.0. I want to setup WAN1 to work with a local Fiber to the home 200/200 connection, and WAN2 is connected to a Comcast Business modem/router combo. WAN2 with the Comcast business connection works just fine, but setting up WAN1 gives me a “WAN failed DNS” test and the connection constantly disconnecting and reconnecting. I will note that I am using the ISP provided ONT/router combo in bridge mode with DHCP turned off, and manually configured the DNS to 8.8.8.8 and 8.8.4.4. This issue happens even with WAN2 not connected and WAN1 is the only ISP connected to the balance one core. Below are the settings I have used for WAN1:

Static IP: 192.168.1.2
Subnet mask: 255.255.255.0
Default Gateway: 192.168.1.1
DNS servers: 8.8.8.8 and 8.8.4.4

I have tried:
Health check set to “DNS lookup” using DNS servers listed above
Health check set to “PING” using DNS servers listed above
Health check disabled

Timeout: 5 seconds
Health Check Interval: 5 seconds
Health Retries: 3
Recovery Retries 3

When I use the above settings with health check enabled, I am able to load speedtest.net and usually run 1 speedtest before the “WAN failed DNS test” error occurs. Then it will disconnect, reconnect, and repeat. When Health check is disabled the disconnect and reconnect rate happens so quickly that I cannot even run a speedtest. I have tried locking the WAN1 port speed to 1000M full duplex, and setting the bandwidth to 1000M/1000M and 250M/250M all without any difference. Any advice on how to resolve this would be greatly appreciated.

Thanks in advance.


#2

By default the LAN IP of your Balance One Core is in the same network as WAN1. The Balance does a NAT from LAN to WAN so if you still have the default LAN network it must be unique from WAN1.


#3

Thanks for pointing that out. Since I don’t connect the WAN1 router to any other devices I could easily change the IP addressing scheme to anything I want without any issues with having to change static IP’s on a number of devices on the network. I’ll try that the next time I get into the office. Would using 192.168.11.XX with the same subnet mask for the WAN1 network work?

Thanks in advance


#4

Yes, that should work just fine but let us know if there is still a problem.


#5

When I was in the office earlier today I was still having the same issue as before. I changed the IP addressing scheme for the WAN1 router to 192.168.11.XX with DHCP turned off. These are the new settings I have configured on the Balance One Core for WAN1:

Static IP: 192.168.11.2
Subnet mask: 255.255.255.0
Default Gateway: 192.168.11.1

Health check set to “DNS lookup” using DNS servers listed above

Timeout: 5 seconds
Health Check Interval: 5 seconds
Health Retries: 3
Recovery Retries 3

I have also tried using IP forwarding from the WAN1 router (ports 1-65535) instead of NAT with the same results. Any suggestions you might have would be greatly appreciated.

Thanks in advance.


#6

@Fiber_man Just to make sure, when you set your Balance One WAN to 192.168.11.x, did you do the same with your ONT router to 192.168.11.1?

Perhaps check with your ISP to see what MTU to use?

Another way to troubleshoot this is direct connection from ONT to your machine.


#7

Yes I set the ONT router (default gateway) to 192.168.11.1 and assigned a static IP of 192.168.11.2 to the Balance One. An MTU of 1400 and 1500 and using auto detected 1500 all produced the same problem I have been facing. A machine connected directly to the ONT works perfectly. Any other suggestions you might have would be greatly appreciated.

Thanks in advance.


#8

What is you try this using WAN2 of the Balance One instead? Based on what I’ve seen so far the most common cause for unstable connection is either something to do with ISP link itself, or MTU. So if possible do find out the actual value of MTU.

If the above doesn’t help, we’ll need you to open a ticket so we can take a closer look, though I’m not sure how stable your connection is for us to be able to do this. By any chance you have a second line or cellular connection that we can make use of?