VPN instability


#1

Hello,

we are finding that the PPTP VPN functionality is pretty unstable requiring the peplink to be rebooted every 4-5 days. What we see is that the VPN starts of stable and then starts kicking people off with increasing regularity the longer the VPN has been up.

Anyone else seeing this? Any hints as to how I can track this down?

Cheers,

David


#2

Hi David,

We have not had other reports of this. If you haven’t done so, please create a support ticket so our team can take a look at this case:

http://www.peplink.com/contact/support/

Thanks,

Tim


#3

I agree. It seems that after a few days my clients cannot connect anymore. Once the peplink is rebooted, they can connect again.


#4

I confirm similar issues. 3 sites each with Balance 380 . Firmware 5.3.6 build 159, Interconnected VPNs via dual adsl in each location and 3g backup connections.

Inter-site VPN 's seem stable however user remote connection via PPTP server deteriorates over time. After a few weeks, users can’t connect, system reboot and all is ok. Currently manually rebooting each week (scheduled restarts would be a nice software feature!).

I had previously suspected that this was a “quirk” of the current firmware.

Laurence


#5

Hi Everyone,

Thank you for reporting the problems. We are working on fix to both PPTP and Site-to-Site VPN issues.

New firmware should be available soon.

Regards,

Matthew


#6

I noticed a similar issue using IPSEC VPN’s via our Balance 580 from our main office to our co-lo. About once an hour or so, Users RDP’d into our TS at the co-lo would complain that their RDP session would timeout for a few seconds then reconnect. I tried tweaking some of the settings on both the 580 and the ASA at the co-lo end, but could never get the stability needed to the co-lo.

Currently we are routing all VPN traffic to a PIX at the main office, dedicating that ISP for VPN traffic only and all other Internet traffic to the 580 which utilizes our 4 other ISP’s.


#7

Hi James,

The issue that you encountered is actually not a similar issue. In your case, this is related to IPsec VPN. IPsec and PPTP are different feature.

If the issue happens again, I suggest to get a Diagnostic Report and send it to us.

Get the Diagnostic Report:

Contact and send the Diagnostic Report to us:

http://www.peplink.com/contact/support/

Thanks,

Lai


#8

Just an update to confirm that the pptp issue remains with 5.3.9 firmware. We have returned to weekly reboots to ensure remote access works each week. Without reboots failures occured in the 2nd week.

Laurence


#9

Laurence, Instead of restarting, just try disabling the PPTP server, applying changes, enabling it and then re-applying changes.


#10

Hello, I experienced the same problems with peplink 380.
Last night I upgraded to v5.3.12 build 1859. Can you confirm this issue has been solved for this firmware?

Thanks in advance


#11

We have recently upgraded a 3 x balance 380 network to version 5.3.12. This issue remains and now seems much worse. PPTP connections start to fail after only 2-3 days now. We have to restart 3 times a week to maintain PPTP service for end users.

This has now changed from an “annoyance” with a short term workaround to a service impacting issue causing loss of functionality to end users.

Peplink please elevate the priority for this. Ticket #728988 has been logged for this issue.


#12

Thanks friend for the information


#13

Peplink support, is there any official statement about this issue?


#14

If you experience the PPTP server issue, please contact us through http://www.peplink.com/contact/support/ . Please also mention this forum post in order to help us to identify the ticket is related to this post. Then we will send you the instructions for troubleshooting, and we want to login your unit for inspection.


#15

An update on this issue:

The Peplink support team have been very responsive. They have tested and confirmed the issue with our customer system. They have installed a test fix which appears to have resolved the problem. This fix should be included in a future firmware update. Perhaps one of the Peplink team would like to post a comment confirming this.

Laurence


#16

Thank you for update. The coming firmware 5.4 will include the fix of PPTP issues.


#17

We too have been suffering with PPTP stability issues. We’re in Chicago and due to the NATO summit most of our employees are working from home and during this time we have 4-6 PPTP sessions at a given time and we’re having to reboot daily.

What is the status of the new firmware to fix this issue?


#18

Gregory,

The Beta fix for this has been on our customer system for several weeks and solves the problem. This was due to be included in the new version 5.4 firmware that was released yesterday. All being well upgrading to 5.4 will make the issue go away. We will be testing this on one of our systems over coming days.

As 5.4 is a major update rushing it into live use has some risks but based on Peplink’s track record of cautious testing and release I would be willing to install it ASAP in your situation.

Good luck. Laurence