VoIP problems with Talkdesk

#1

Have a client using Talkdesk, which is a VoIP-type product that uses both a desktop app and a browser-based (Web-RTC) app for calls.

We keep seeing dropped calls. We have brought in fios to augment cable service, verified that we have enough bandwidth, set “voip protocols” to high priority in the QoS section yet still have issues.

Talkdesk wants more changes, none of which seem to be available on the Peplink:

  • Setup destination-based QoS rules to prioritize voice (Peplink only supports source IPs) to Talkdesk’s servers
  • Setup DSCP rules to try to catch/prioritize the softphone traffic
  • Turn off all SIP “helpers” (ALG) - this does not appear to be an option (why not??!??)
  • Check and possibly increase NAT UDP timeout for sessions (I think this is actually the problem - peplink doesn’t see this non-standard VoIP as VoIP and aggressively terminates NAT sessions)

The last two really bug me, am I just not seeing those options or are they really not adjustable?

0 Likes

#2

Network > Service Passthrough > SIP. Select Standard Mode

We have no trouble with actual SIP phones. Using desktop apps and browser based soft phones in my experience is typically lousy.

1 Like

#3

What does “standard mode” do though? The tooltip has no straightforward answer about what either mode does. I want zero “help” from the firewall on this. Just nat it and let the provider’s Session Border Controller deal with it.

We work with two large VoIP providers and both always have “disable SIP ALG/proxying” as one of the first issues on their troubleshooting list. These days VoIP providers/SIP trunk providers generally run an SBC and prefer that we let their SBC deal with fixing things up, not the client’s firewall…

0 Likes

#4

Standard mode is exactly what you are asking for. The router is not doing anything to “help.” I agree its not very descriptive. Its been discussed here in the forum before.

1 Like