VoIP Issue on Peplink Balance 305


#1

Hello,

We are having some issues with our VoIP system…I think it is a NAT issue.

We have a central data center that houses our PBX System (Digium Switchvox). We have 19 remote sites that all have VoIP phones, that register/interface with our PBX.

Each Site has a SonicWall, and we have one at our Corporate Location. The SW catches all the remote traffic is passes it through a tunnel back to our Data Center.

The Corporate SW had a default gateway to a router that we are in the process of removing (Cisco Router, was also a WAN Connection). After the SW people changed from pointing to the Cisco Router, to the Peplink as the default gateway. All of our VoIP phones are not reporting their IP as the Peplink IP, in the PBX system.

We also have an Edgewater Router at each store, which connects to our PBX, which allows a cordless phone and an intercom system to interface and have extensions on our VoIP system (can dial extension for Intercom from a phone and talk over it). These two functions quit working after changing the default gateway from the Cisco Router to the Peplink.

I think if we can fix the IP issue we are seeing, this may also fix the issue with the Edgewater and the two devices connected to it.

Normally phones are a site would be A.B.C.101, A.B.C.102, A.B.C.103, etc. In the PBX they would all register, showing those IPs. Now, say our Peplink is A.B.C.100, after the Gateway change, all the phones register as A.B.C.100

Any help would be greatly appreciated. Also if you need any further information, please let me know and I will provide what I can.


#2

@MIS_Admin, I would be more than happy to help you solve this issue. Reach out to me and we can look at your configs. I don’t think this is a 305 issue and more a VPN / routing issue. My email is peter@westnetworks.com


#3

A network diagram would help us make suggestions here, but Peter is right - smells like routing issue.

You could try enabling IP Forwarding on the Peplink’s WAN to take NAT out of the equation, but your PBX will need to know how to route back to the remote sites hanging off of the back of the sonicwall via the Peplink now (instead of the Cisco) - which might just come magically right if you swapped out the Cisco for the Peplink and used the same IP on the Peplink as was on the Cisco. You’ll likely also need to add static routes for the remote sites behind the SW to the Peplink with the sonicwall IP as the next hop.

The only other question is if the Peplink is doing its job with SIP ALG/rewrite, and so turning on compatibility mode in Network > Misc. Settings | Service Passthrough might help too.


#4

Hi!

Thank you for the reply. I am currently trying to get some software or a network diagram, so you can see the before/after on what our setup looks like.