VM appliance DB-Incontrol


#1

Hi guys,

Self-hosted InControl based on two VM’s. First of them (InControl) booting fine and it looks like it works well. I didn’t have possibilities to test whole system because second VM (DB-Incontrol) doesn’t fully boot (system halt on data disk initialization step). It is looks like some error in command which is responsible for preparation/formatting second drive for data purpose. I tested it in two environments (Proxmox and Virtual box, both have exact the same problem).

Below you could find short description what I have done and where I meet issues.
I have a two VMDK files which I converted and imported (as a .raw) to Proxmox VE 5.2 (or as a .vmdk in Virtual box) without any bigger issues. These VM images include a web server and database server based on Ubuntu 14.4 and both require additional disks for the database purpose. For some reason, DB-InControl VM is not able to initialize/mount the DATA_DISK under the first run procedure and halt entire VM installation proces. I tried a few different things as a different setting for BUS/Device (IDE, SATA, SCSI, Virtio), different storage pools (SSD,HDD), manually formatting data disk etc. but DB-VM still can’t initialize/mount attached DATA_DISK or formatting it by mkfs (because no device name given in argument list). I configured two of IDE controllers (as Peplink described in manuals for VMware installation, difference is that it are two separate controllers not as described IDE0:0 IDE0:1 master/slave). It is an on-premise solution and I don’t have a root access there to check logs which could provide more information. The recovery boot option doesn’t help me too. Problem is that all manuals which I found pointing to VMware or HyperV virtualization platform and only a few topics on Peplink forum talking about problems related to on-premises systems.


Could I ask you for some directions, or offer/price to help me solve that problem for current Proxmox hypervisor?

Best Regards
Christopher


#2

ESXi and HyperV are the only supported virtualization platforms for self hosted IC2. Others may have been able to get this running on other platforms, but we do not officially support this.


#3

Hi Travis thank you for response.
I have always been impressed by the great work that Peplink is doing and I can only imagine how hard they have worked to achieve this level of services integration. I fully understand that Peplink can not support all vm platforms and I understand which platforms are supported. Proxmox based on Debian Linux distribution with a modified Ubuntu LTS kernel. DB-Incontrol based on UBUNTU 14.04. in theory both systems should be compatible. Bay the way I talked with my older colleagues (from other company) who failed to install InControl even under VMware ESXI and decide to buy ICA-LC-500 to be able achieve this goal. This forum is probably my last resort. I will appreciate official/unofficial or paid help.

Best Regards
Christopher


#4

I am following up your support ticket over email.


#5

Dear Michael,

Thank you so much. Received from you link to DB-VM which you prepared, woks fine with Proxmox platform. Database server boot up now without any issues :slight_smile:

I appreciate your professional support and knowledge.

Best Regards
Christopher