VLAN's with own DHCP server Balance 305


#1

Hi,

I have a question, not sure if the peplink balance 305 supports for what i want to achieve.
I use a peplink balance 305 for routing all the network traffice.
I created 3 VLANS on the LAN settings on the peplink,
1 default with ip and dhcp 192.168.2.1 (VLANID n/a)
2 WiFi with ip and dhcp 192.168.3.1 (VLANID 10)
3 Test room with ip and DHCP 192.168.4.1 (VLANID 11)

underneath the peplink i configured a netgear switch with the corresponding VLAN ID’s.
I am doing something wrong i think, because on all of the ports i untagged as VLAN 10 or 11 i still get an IP adres of 192.168.2.1 (default vlan)

does the peplink supports this functionality??

Thank you!


#2

Peplink supports the 802.1Q networking standard for VLANs so make sure the switch also supports 802.1Q VLAN tagging.


#3

Hello,

Yes the Balance does support VLAN Tagging.


Referencing the image above, click on the (?) next to LAN to enable the VLAN feature.

Once configured, in the switch, double check your settings.
NOTE: The port on the switch that the Balance is plugged into will need to be tagged with your tagged/untagged VLANs.


#4

@Jarid Peterman i configured the balance just like the image, my switch (Netgear GS728TP) also support 802.1Q networking standard.
I also taged port 1 of the switch wich is connected to the balance as the trunk port.

I untagged port 3 as VLAN 10
I untagged port 4 as VLAN 11


#5

Hello,

Do you mean that port 3 is setup to get DHCP from VLAN 10 and Port 4 to get DHCP from VLAN 11? Looks like you have things setup correctly, are there any issues at all?


#6

Hi Jarid,

Yes that is what i want to achieve, but the problem is that when i plug my laptop in port 3 or 4 i get an ip adres of the default VLAN not the VLAN i want / need an IP from.
that’s the hole problem :slight_smile:
haven’t worked much with netgear switches but it seems right to me, also first time trying vlans with peplink so not sure what is going wrong…


#7

This means the Netgear switch is not configured correctly, please check with their tech support.


#8

Also,

Check the port that the balance is plugged into to ensure it is tagged for VLAN 10, 11 and the untagged VLAN.


#9

Hi all,

I had contact with netgear support, the checked my config for the netgear switch and told me it is good the way i configurerd it.
Het told me i needed to tag vlan ports on the balance for the packets to be transmitted to the right VLAN on the balance.
But in earlier support contact with peplink they told me this functionality is not available.

I’m stuck now, but is there a switch wich has been approved by peplink to work with what i need?

thank you!


#10

Hi Xplo-IT,

if the switch is managed and supports VLAN and standard 802.1Q trunking it should work fine for you. just make sure that you have the VLANs created on the balance, and then the port on the switch that is plugged into the balance is “Untagged” on the native VLAN, and tagging 10 , 11 traffic, this should allow the traffic to flow with the correct tags to the balance which will then handle the packets. I think the other function you are asking about is a “Per-Port VLAN” which you would like to tell a specific port on the balance LAN that is essentially an access port for a specific VLAN instead of just trunking, is this correct in what you are looking for?

thanks,
Taylor


#11

Hi Taylor,

Yes i want to do a per port VLAN but was told this is not yet supported by peplink balance.
I have managed to create a new network for quick solutions that where needed but stil want to create my vlans as mentioned above.
Whith the netgear switch i am not abble to achieve what i want, i now want to buy a good switch from HP.
The switch needs to support VLAN with the 802.1Q standard and then i should work right?

thnx.


#12

Yes, HP procurve should do just fine, and i have used them in many scenarios. Most HP’s today should support the VLAN / 802.1Q in the managed switches such as the 2510 series. If you need help finding a switch model that fits your needs, I think you may have been working with our colleagues at the FrontierBV office in the Netherlands, so i’m sure they can help you get a unit as well if needed. let me know if you need any help

thanks,
Taylor


#13

Hi Taylor,

Yes FrontierBV in the Netherlands is supplying the hardware, we want to use this one:

http://www8.hp.com/h20195/v2/GetDocument.aspx?docname=c04394247

It supports the 802.1Q standard, i just want to make sure i use a switch which is compatible with the balance 305.


#14

Yes that switch should work just fine. I have used many different models HP Procurve with no issues. I would expect no issues being compatible with the 305.

thanks,
Taylor


#15

Thanks Taylor, wil try and report back!


#16

Hi,

Just for some help with the HP

1)configure one port of the switch as trunk and tag all the vlans.
2) connect the LAN side of the Peplink to the port you have configured as Trunk
3) configure the ports on the switch as “untagged” with the vlan that you want, ie port 1 vlan 10, port 2 vlan 20 and so on
4) make sure that you do not configure an interface ip on the switch except for the default vlan and make sure “inter-vlan routing” is disabled (so you will force the packets to route through the Peplink)
5) default gateway for your devices will be the IP address of the Peplink VLANs

Let me know for any help,

Charris Lappas


#17

Hi Guys,

Got the new HP Switch working today, VLAN’s where added and when using a static IP adres on a client computer using the appropriate VLAN port everthing works fine.
So then i went to DHCP relay on the HP switch, configured this but, DHCP is not working.
Seems like the broadcast for DCHP request is not getting tru to the peplink.

anny ideas? or do i need HP for this?

Thanx!


#18

Hi,

You should not need to configure the HP switch with DHCP relay since your Peplink which acts as a router (default gateway of the PCs) should be able to pick the request for a DHCP.

Please perform the following and let us know:

  1. configure one PC with static IP, subnet mask and default gateway

  2. connect it to the appropriate port of the switch port you have configured.

  3. ping the other interfaces (VLANS) of Peplink or simply browse the Internet

  4. If everything works then it is something of the DHCP configuration of your network

  5. if you cannot browse the Internet or cannot ping the other (VLANS) then something is wrong with either your Trunk or the switch port (not defined correctly).

Have you checked my recommendation on my previous post?

Let us know,

Charris Lappas


#19

Hi Charris,

Yes i used your recommendation, when i use a client client with a static IP i can ping the other VLANS and can browse the internet so the VLAN config on the switch should be ok.
Just couldn’t get DHCP running, by my knowledge DHCP request goes via Broadcast and would need a DHCP relay, this indeed doesnt work, but with the DHCP relay turned off it doesn’t work either.
Wil be back in the office tommorow, will check the DHCP on the balance but there is not much to configure i think.

Thnx.


#20

Hi,

The DHCP relay is used in cases where the DHCP server is located in another VLAN and is not the router. So you define on your router the DHCP relay, so in case there is a broadcast on that VLAN for a DHCP, the router knows where is the server and the router goes and gets the ip info and sends it to the pc. In your case you do not to configure the relay anywhere.

I have send you a personal message for more help.

Thanks,

Charris Lappas