Very Slow VPN Client connection over PPTP


#1

Hello,

We have a Balance 305 that we have a PPTP remote connection set up on for client pc’s working remotely. We’ve found this connection is very slow, with our uploads speeds so slow that they regularly time out or disconnect. We’ve done some testing and found that even when our office is empty on the weekends and only a single user is connected via vpn, the connection is still the same slowness. Are there any settings we might need to pay attention to to speed things up or any suggested methods for troubleshooting this issue?

Thank you.


#2

Hi,

  1. Which LAN device PPTP users are connecting to and encounter the slowness? Have you try to connect to other LAN devices? Same result?

  2. Have you check the bandwidth usage (Status > Real-Time) when problem occur?

  3. This happened to all or specific PPTP user?

  4. Can you share the MTU setting of all the WAN ports?


#3

Thanks for your reply.

  1. Most users are just accessing shares from our file server. We’ve tried RDP to a few servers but they time out before connecting. We use Outlook Anywhere but I could try routing mail traffic over the VPN to see if I get the same result. I can’t think of any other services that I could test with, but I will have a deeper look.
  2. I haven’t checked bandwidth usage, When testing, the PPTP connection we were using was the only active connection on firewall so I didn’t think to watch the monitor. I will try the test again this weekend and watch the real time monitor while testing.
  3. This issue is affecting all users connecting remotely from local, national, and international locations.
  4. Both of our WAN ports MTU are set to 1440.
    Thank you for your help!

#4

The WAN MTU setting could be the culprit here, please try Auto or 1500 and see if this resolves the issue.


#5

Thank you for your suggestions. We’ve tried both Auto and 1500MTU but haven’t noticed much change. We’ve found our initial connection time to be slightly faster when verifying username and password, but are still seeing less than 1KB/second upload speed when copying small files to a share on the file server.


#6

Hi,

This is strange. PPTP wouldn’t limit the bandwidth. I suggest open ticket for us to do further checking.

I need your favor below.

  1. Create a PPTP account for technical support to access.

  2. Prepare a testing PC for technical support to test RDP and file transfer.

  3. Enable Remote Assistance on this affected unit.


#7

Thanks for your help.
I don’t currently have a support contract in place for my appliance so I’m waiting for a PO to be approved to purchase Total Care and then I will open a ticket for this.

In the meantime I’ve tried switching over to IPSec to troubleshoot the issue but it doesn’t allow me to connect. I get error 789 when I try to connect. Any settings need to be changed or rules created for IPSec to work with my Balance or might this be related to the same issue?
Thanks!


#8

Hello,

We don’t require a support contract for technical support so as TK mentioned feel free to open a ticket so we can go more depth with you there to help troubleshoot.


#9

Oh, that’s great! I’ll still be ordering TotalCare anyways but I will open a ticket now. Thank you.


#10

Are the remote devices Windows PCs using Windows native PPTP? If so, the Windows default is that once connected via PPTP, the Windows device will send all network traffic through the PPTP connection. That includes all general internet traffic, most of which is probably sourced on at your home base. That puts a great load on your home base available upload speed. With multiple users doing general web browsing and such things not related to your own home base servers, that would account for slowness.

Prior to Windows 10 there is a WIndows network setting in the IPV4 properties, advanced properties, uncheck “use remote gateway”.

With Windows 10 this check box has been eliminated but can done in a windows powershell running as administrator:

set-vpnconnection -name “vpnname” -splittunneling $true -passthru

You can use the powershell for this configuration prior to Windows 10 but its easier to use the first method.


#11

Thanks for the suggestion. I’ve double-checked all the native VPN setups on the machines we’ve been testing with “use remote gateway” is unchecked for all of them. I’m not sure if this is a bandwidth issue as I’ve tested after business hours when the network is quiet and still had the same issue with file transfer speed.

I’m curious to try the same tests over L2TP and see if that makes a difference but I get a 789 error when I try to connect. Are there any special settings in the native Windows connection or Windows firewall that need to be changed in order to get L2TP to work?


#12

The only thing that needs to be changed that is different then PPTP is adding the secret shared key.



#13

I changed that and this is what I see.


#14

Hi,

As suggested earlier, the best way is open ticket for us to take closer look. We need to do further investigation.

Thank you.


#15

Thanks. I already have a ticket open, I’m just following up on this thread until I hear back from a tech.


#16

A while back I started using PPTP and found it to be slow too. When researching the protocol I found that it has a lot of security issues: https://en.wikipedia.org/wiki/Point-to-Point_Tunneling_Protocol

So I switched to L2TP and found it to be much better–zero performance issues.

Here’s how to configure windows10 clients: https://www.cactusvpn.com/tutorials/how-to-set-up-l2tp-vpn-on-windows-10/

When this is set, all traffic goes through the VPN. To setup up split tunneling, there is a powershell command to do this: https://forum.peplink.com/threads/5324-Split-tunneling-option-for-L2TP-connections-to-MAX-Routers