Verizon U620L and Surf SOHO


#1

Anyone know if the new Verizon Novatel USB modem U620L will work with the Surf SOHO?

thanks,
Phil


#2

Hello,

It is currently not on our support list however if you follow the instructions on the bottom of the below link our engineering team should be able to create a special firmware for you.


#3

Hi Team,

I know Engineering has begun work to support the modem from a separate case. Stay tuned!


#4

Hi Phil,

Novatel U620L is supported on the custom firmware 6.2.1s064.

http://download.peplink.com/firmware/soho/fw-surf_soho-6.2.1s064-build1791.bin

Thanks,
Samuel


#5

Is there a firmware for Balance20 that will support the U620L? I’ve put in a support request but have not heard back yet.


#6

Hi,

Engineering team will feedback on this. Please check your ticket.

Thank you.


#7

Can you create a firmware for the Surf on the Go and the Verizon U620L. I just purchased several SOTG to use in our ambulances.


#8

Hi,

For your Balance 20 please upgrade it with the firmware 6.2.2s016.

http://download.peplink.com/firmware/plb30/fw-b20_30-6.2.2s016-build3020.bin

Thanks,
Jordan


#9

Jordan can you provide a firmware for the Surf On the Go using a Verizon Novatel U620L usb modem


#10

Hi,

Please create a support ticket for supporting Verizon U620L modem on Surf OTG.
https://contact.peplink.com/secure/create-support-ticket.html

Thanks,
Jordan


#11

I am getting “Invalid Firmware Image” when I tried updating to this firmware.

I have a SOHO and also need a firmware update for the U620L. Can you please help! I need to get this going so I can get my wife’s IP phone working.


#12

That is an old firmware build, please use this one instead:
http://download.peplink.com/firmware/soho/fw-surf_soho-6.2.2s003-build1800.bin


#13

I get a firmware corrupted for both the 1791 and 1800 builds of the firmware listed on this thread. Can someone point out a valid firmware d/l so I can get this working?


#14

Hi John,

We have released firmware 6.3.0GA recently, you may download this version of firmware for Surf SOHO at here.

Thanks and regards.


#15

Tried the d/l with both Chrome and IE 11 and get an “page not found” screen immediately after clicking on the upload button. This is the same for all three updates. When I refresh the page I get the invalid or corrupted message.

Thoughts?


#16

Appreciate if you could send us a screenshot of the exact error message that you are getting.

You may just want to send us a diagnostic report to us via our ticketing system so we can take a closer look:
https://contact.peplink.com/secure/create-support-ticket.html


#17

I opened ticket #75840. The tech suggested I d/l this firmware:
http://download.pepwave.com/firmware/sotg/fw_010027_build_1265.bin

It installed and the modem works as expected. Thanks!