Verizon SIM card is stuck “obtaining IP Address”

I have used this SIM card before, but we do move around. My ATT SIM card works well, but unfortunately where we will be located there is only Verizon service, so need to troubleshoot why this card is not working. We have rebooted the router (Pepwave BR1 mini) and tried the card in both slot A and B with same results.

Firmware: 8.0.0s061 build 3484
APN is defaulting to vzwinternet (which I believe is correct).

What else do I have to try?

what verizon plan? when was the last time it worked?

It’s an unlimited data plan (well as unlimited as the plans are, 40 gig).
It last worked 5 days ago in Red Bluff, we are now 400 miles away from that location)

Shana M Lakso

you arent telling us what plan… what is the exact name of the plan in their system?

does the device compatibility bands and tower bands available align?

Exact same thing is happening to me. Been using 2 Verizon SIMs successfully in my HD4 for 2 months and a few days ago both of them got stuck on “Obtaining IP Address”. I’ve updated firmware (router and modem), definitely checked the APN, and tried all sorts of settings/changes to no avail. It’s extremely frustrating. Put a ticket into Peplink but no reply…

So interestingly enough, I am having the problem. Connection was fine for two weeks. Then I logged into to admin interface and noticed the cellular signal graphic was missing just for cellular. So I tried dragging the connection to disabled and then back to priority 1 to no avail. Stuck on obtaining IP. I finally rebooted the whole unit and it was resolved, instantly connected to the AT&T network. I have never seen this before. I saved a diagnostic log at the time and have shared it with Peplink support.