Verizon Prepaid Unlimited Tablet/Jetpack plan stopped working with Peplink

I’ve been using the new Verizon $70 prepaid unlimited tablet/jetpack plan connected to a hotspot, previously the crummy Mofi device and now Peplink MAX BR1 MK2 LTEA.

This Verizon SIM been working great over the last few months, but just last week stopped working. The Peplink hotspot is connecting to the LTE network just fine, but none of my devices (computers, phones) connected to Peplink can access the internet. The Peplink itself can ping internet resources and passes HTTP health checks just fine. But anything connected to the LAN fails to connect to the internet.

If I throw the same SIM in an cellular iPad, the iPad can access the internet just fine. However, if I try to enable tethering on the iPad, the same issue occurs: no tethered devices can connect to the internet.

Anyone else seeing this? It’s as if Verizon is now blocking tethering/hotspot capabilities on this tablet/jetpack plan.

To follow up: I spoke to Verizon Tier 2 support. They were able to make a change to my account that fixed it… for now. They had been apparently blocking the Pepwave. Despite being certified, they said it wasn’t listed as compatible with a prepaid hotspot plan. Hopefully it’ll continue working.

Hi Sirris101,
Most carriers will block devices such as routers from their unlimited plans since those plans are associated with fewer devices compared to what can be behind a network router. There should be a M2M plan provided by the carrier which will not/should not be blocked. I don’t know if this is exactly what you’re experiencing with Verizon but based on your forum post it’s the most likely reason.

Thank you

Thanks Collin. Seems to be the most reasonable explanation. Luckily the Tier 2 seems to have enabled the Peplink on my account; hopefully it sticks.

I am glad to know that it now works. It always good idea to contact the administrator whenever there’s an issue.

Sirris, do you have any additional details on what was changed on your account?

I’ve been dealing with this for a while (not unlimited, but prepaid plan) and the support people even at tier 2 are not very helpful.

I get stupid instructions like confirming the SIM number off the card, must reboot my computer after I remove my WiFi from the list, etc.

I know this is telco side. I worked at a telco and I’ve yet to find someone on their end who does more than run the support checklist.


I wish I knew specifically. My guess is someone at Tier 2 whitelisted my specific device.

I just provisioned my Verizon Jetpack 8800L prepaid plan sim on the Max Transit Duo about 3 weeks ago and have had zero issues - APN = VZWINTERNET. I’m using Speedfusion (Solo on Vultr LA) to bond this with ATT tablet plan sim - APN = BROADBAND, also no issues.

Just lucky?