USSD with actual reply from ISP

We are using approximately a dozen MAX BR1’s with prepay cell service. The devices are working great but it is a problematic to have to remove the SIM and stick it in a phone to load credit, buy internet packages/bundles, or basically anything that utilizes USSD codes. Is it currently possible with the existing SIM Toolkit USSD support to display actual replies to commands that are sent and not just display “Request sent successfully”? If this is not currently possible how can we get this added because it would be really helpful?

Here are some examples of what this looks like:
Check Balance
Send *102#
Reply “Your balance is 1.00”

Add Credit
Send 1041234567890987654321#
Reply “1.00 added to your account your new balance is …”

Buy internet Bundle/Package
Send 14866#
Reply “1 - Phone Bundles
2 - Internet Bundles
3 - Check Bundle Balance
4 - Change Language”

Send 2
Reply “1 - Day Bundle
2 - Week Bundle
3 - Month Bundle”

Send 3
Reply “1 - 1Gb for 2$
2 - 5Gb for 5$
3 - 10Gb for 7$”

Send 3
Reply “Do you wish to buy 10Gb for 7$ 1-Yes/2-No”

Send 1
Reply "Thanks for subscribing to the 10Gb monthly bundle.

Sorry for the formatting on the examples but hopefully they make sense.



I like this request a lot. And would also request that the SIM toolkit is made available via the IC2 API so that we can automate the top up process like champions.


I will move this to feature request for the team to take consideration.

Thank you for your suggestion!



Regarding this feature request, how can I stay on top of this? This would be a very benficial item for my team and I would like to keep track of its status within the pepwave development process.


I have checked. The requested feature was supported. Please upgrade to this firmware -

Below is the screenshots I tested with this firmware.

  1. I purposely enter an invalid USSD code

  2. I enter a valid USSD code

  3. I choose 1

  4. I choose 0

  5. Back to the main menu as expected



First let me say that I am really impressed with how you took feedback from your customers, evaluated it, and actually implemented. Its the way things ought to work but in reality rarely do. A huge thanks to you and your team!

I upgraded one of our devices from “6.3.3 build 2252” to the build you posted “6.3.3s047 build 2342” unfortunately I still get the exact same behavior as before. I tried several different types of codes but they all respond with “Request is sent successfully”. One time I actually received ERROR but I have not reproduced that again. What do you need from me to debug why your setup is working well but mine is not; because yours screen shots looks like what we were wanting?


Please do me favor below:

  1. Remove the SIM card from BR1 and put into mobile phone.

  2. Try the USSD code on mobile phone.

If the USSD code works on mobile phone, please help to open ticket. Below is the info needed for us to do troubleshooting:

  • USSD code and the steps you tried on mobile phone (similar to the screenshots I provided) which is working fine.

Thank you.

1 Like

The USSD feature was broken on my BR1 with the 6.3.3 build 2252 firmware update (worked fine with firmware 6.3.1 build 2023). I used to be able to use USSD codes that were enclosed in hashtags (like #123#). These are required by my ISP to purchase credit, etc. However, under 6.3.3 when I try to use codes enclosed in hashtags I get the error message “invalid USSD code”. I have confirmed the problem was introduced in firmware 6.3.3 because I reverted to 6.3.1 and the codes surrounded by hashtags are working just fine again.

Could you please correct this?


On another note, it_mbeya, I have also had problems receiving nothing but a response of “Request sent successfully” when entering USSD codes. It doesn’t happen all of the time but I would guess that it occurs 30-40% of the time, sometimes in the middle of a menu. My guess is that it has something to do with the Pepware not processing the return response properly, or perhaps timing out before the system on the other side responds. I NEVER have this problem with my SIM in a mobile phone, so it is definitely a Pepwave problem. I have found something that can help, however, through trial and error. When you receive this response, type in the same USSD code that you began with. Let me give you an example:

  1. You want to enter the buy credit menu, so you enter #123

  2. You receive a menu like this:

How much talking time do you want to buy?

  1. 60 minutes

  2. 120 minutes

  3. 23 milliseconds

  4. You enter “2” for 120 minutes.

  5. You receive the menu:
    "You will receive 120 minutes of talk time for $1000 (bonus sale today!). Press 1 to confirm, press 2 to cancel.

  6. You press “1” to confirm, but instead of getting the next menu item, all you get back is “Request sent successfully.”

  7. Do NOT try to re-enter the “1” again to try to confirm the purchase. Rather, enter the USSD code that started the menu you’re in. In our example, that would be “#123”. At least with my ISP, this brings me back to the step in the menu that failed. (Press 1 to confirm, press 2 to cancel).

While still a pain in the neck, because the “request is sent successfully” failure happens often, at least I don’t need to start at the beginning of a long menu again and cross my fingers and pray I’m able to get through it without a failure. Hopefully this will help you.

I’m hoping someone at Peplink can solve this “request is sent successfully” problem when sending USSD codes. In any case, good luck, it_mbeya. Hope this helps!

@TK_Liew: The USSD codes work fine in a cell phone or USB modem so I went ahead and opened a support ticket on Friday as requested. Hopefully with suports help we can get this feature working well for everyone.



Thanks for the info!


Please try the firmware that suggested here. Please open ticket with the required info if this firmware doesn’t help.


1 Like

Hi David,

Noted and thanks!

1 Like


I was about to request such feature then I found this post.

Thing is that I never saw a menu actually appearing while using USSD. Is it possible that the feature was broken or not implemented on HD4 with firmware 7?


Would you able to screenshot the USSD page and share here ?

1 Like

Hi Sit Loongs,


This code should display a menu like in the example above.


7.0.4 build 3290


1 Like

Just to check the #225# is a valid code ? and it suppose to return what service option ?

Would you please open a support ticket for support team to check ?

1 Like

The exact same code works now and I can even do chained commands #225#XXX

I have forced the modem on one sim, maybe it helped.

When you click on the submit button for the USSD code, it will send out via the active SIM. Base on the screenshots given, the SIM cards IMSI info are different, suspect that the same USSD code is invalid for SIM card IMSI ended with 4384. Would you please confirm ?

Good to heard that it wok for you now :+1::+1::+1:

1 Like

all ok, it is the same provider but on card level issue then.


1 Like

Is there a list of USSD codes for verizon and/or verizon prepaid?