Using Windows DNS Server on VLAN 1


#1

My company wants to switch our firewall with a balance 20 & when I created our private default network I see an option to Enable Proxy DNS Server and there is a place to specify DNS servers below. My problem is that when I put our windows DNS servers in the Peplink required me add host names for both my windows DNS servers. I put the host names in but I find it strange that hostnames were required. I have never been required to put in a hostnames in before just IP addresses. What’s even more strange when I created other vlans the DNS server fields for each vlan did not require host names and seems much more straight forward & similar to what I’ve seen in other routers. I’m not sure if I am doing this right. Can anyone tell me what are the standard settings for putting in windows servers (private addresses) in the default vlan?


#2

Are you referring to “Local DNS Records” below the DNS proxy settings which would require host names?

If you have external Windows DNS servers on your LAN you would un-check “Assign DNS server automatically” then enter your DNS servers by IP address in the Balance LAN DHCP server settings.

The Balance DNS Proxy is not used when LAN clients receive your private DNS servers.


#3

Something seems messed up here. The only way I can specify DNS servers for the default vlan 1 is to enable DHCP which I don’t want to do because we also have an external server for that. If I disable DHCP I no longer have access to the DNS server settings in the DHCP server menu & the check box is checked for “assign DNS servers Automatically”