Using PepLink as a switch slows WAN access


#1

When I connect a computer directly to my cable modem, I get a speedtest.net result of 58 Mbps download speed. But if I run the cable modem through my PepLink Balance 30, the best I can do is 10Mbps download.

I’ve tried adjusting the settings various ways and turning off my other WAN connection (using the PepLink as a switch and not a load balancer). I’ve also tried using default settings. No luck. Is there a setting on the PepLink that could be causing the degradation in speed?

Many thanks for your help,

Christian


#2

Hello Christian,

To try and figure out what might be going on the Peplink side of things would be to get a diagnostic report from the unit while you are having the issue. Instructions to get the report can be found at the following link-

Once you have the report, head over to Peplink.com and create a service ticket and attach the report. Once we have the report, we should be able to see more of what might be going on.

Best Regards,

Jason

The Peplink Team


#3

Also, whatever you set your link speeds at in the WAN setup are the max speeds that the router will provide. Double check the setup for your download and upload bandwidth values.


#4

Christian,

I had exactly the same problem with my Balance 20 and I believe I fixed it by following advice in another post to change the port speeds for WAN1 and WAN2 from “auto” to 100FDX or 1000FDX as appropriate.

Eric