Using mix of Internet (3G) and point-to-point links between two SpeedFusion units


#1

Hi,

I’m new to the forums. We’ve recently bought a Pepwave Max 700 and a Peplink Balance 310, to handle a connection between two buildings.

We’re using 4 lots of 3G modems on the Pepwave, and these connect to the Balance’s public IP, on the Balance’s WAN1 port. And that works fine. We can run a Speedfusion VPN over these four links no problem.

But then we want to use two point-to-point links. These are effectively (for testing) one cable going from WAN1 of the Pepwave Max to WAN2 of the Balance. And another from WAN2 of the Pepwave Max to WAN3 of the Balance.

We’ve set each point-to-point link on a separate network:

POINT-TO-POINT LINK 1
The Peplink end of the point-to-point link (PeplinkWAN2) has IP 192.168.41.1
The Pepwave end of the point-to-point link (Pepwave WAN1) has IP 192.168.41.5.
Subnet mask is 24.

POINT-TO-POINT LINK 2
The Peplink end of the point-to-point link (PeplinkWAN3) has IP 192.168.42.1
The Pepwave end of the point-to-point link (Pepwave WAN2) has IP 192.168.42.5.
Subnet mask is 24.

All connections show as active on WAN Connection Status.

But I’m confused about the gateway field for each side of each link, which seems to be required before the settings will save. I don’t think it really makes sense to have the concept of a gateway in this point-to-point situation. It’s simply a network with two devices on it. The problem is that the config box forces you to enter one.

I initially entered the IP address for other end of the link into each device’s gateway field. So the for LINK 1, the Peplink Balance had a gateway of 192.168.41.5 and the pepwave a gateway of 192.168.41.1. That caused routing issues — the symptom was that (once VPN was established) I could run a ping in the terminal, and every minute or so I’d get a succession of lost pings.

I then changed the peplink’s gateway field, to point to our main gateway (which is on WAN1). This worked fine (though doesn’t seem logical to me to have a gateway on a different subnet!)— but I ended up with the symptoms above, where the point-to-point link won’t re-establish. Logically, I think that gateway field should be blank!

I can get a VPN up and running over the point-to-point connections plus 3G modems, but I find that if I unplug the point-to-point connection, then plug it in a minute later, the Speedfusion VPN will not discover that it’s reconnected (although it shows as active again on WAN Connection Status).

So I suspect maybe some weird routing issue that happens when the VPN is connected.

One other thing to note — we are doing Layer 2 over the Speedfusion VPN.

One final thing ---- in the Speedfusion settings (Pepwave), we had entered the public IP address of the other end of the link (which terminates on the Peplink’s WAN1 connection). And we’d also entered 192.168.41.1, eg. the WAN2 interface of the Peplink above. That worked fine. When we added the second point-to-point link, we also entered 192.168.42.1 (the IP address of WAN3 on the Peplink). But the VPN would not connect at all (even over the 3G links) when that was entered. I noticed the warning in the help popup for this field, which says:

You may enter only one of the remote unit’s WAN IP addresses/host names here even if it has multiple WAN connections

So, should I only enter the public IP address of the Peplink here, and not the WAN2 or WAN3 IP addresses? If I do this, the VPN doesn’t seem able to use the point-to-point links. I’m not sure how the Speedfusion VPN can locate the other side of the point-to-point links if it doesn’t have this IP addres entered — and yet the warning seems at odds to this!

Does anyone have any pointers for using point-to-point connections in addition to regular Internet connections?

Thanks…

Tom


#2

Hi

I just wanted to add the firmware versions we are running.

Pepwave Max 700 is on firmware: 5.4.1 build 1608

Peplink Balance 310 is on firmware: 5.4.1 build 1285

Thanks

Tom


#3

Thanks for your elaboration, Tom.

For your P2P link we might want to use IP forwarding mode instead of NAT mode. Section 11 Configuration of WAN Interface and Appendix B.2 Routing via IP Forwarding will walk you through it. Have a look and see if it helps.

SpeedFusion fails to establish on a link after it goes down and up - we will need you to please submit a support ticket here for us to take a closer look at it.

And lastly, you should still include IP address of peer Peplink WAN2 and 3) under MAX SpeedFusion setting. The help pop-up message should read that even if you enter only peer Peplink WAN1 public IP, MAX will still be able to establish SpeedFusion to Peplink WAN2 and 3 after establishing a SpeedFusion to Peplink WAN1 and discover the IP addresses of other Peplink WAN interfaces for SpeedFusion connection. But of course you are recommended to enter IP addresses of Peplink WAN2 and 3 as well for an extra layer of resiliency in case Peplink WAN1 ISP is down.

MAX should still be able to establish SpeedFusion with or without Peplink WAN2 or WAN3 IP. We will take a closer look at this via our support queue. Thanks for raising this.


#4

Thanks Kurt,
I have logged this on Toms behalf [Ticket #730651] and asked him to get the reports sent asap.

Kindest,
Martin


#5

Thanks Martin and Tom. We will sort this out then :slight_smile: