UPNP VLANS Subnets (synology NAS + minimserver/minimwatch bubbleupnp server/bubbleupnp)


I’m not sure if I should be asking here or in the minimserver or bubbleupnp forums, There’s a bit of a story to explain where I am and apologies if this is the wrong place. The router has so many options… it’s great so I am hoping there is something that I can setup to allow it all to work.

I’ve been setting up my network at home and trying to learn and use the functions available on my balance 20x.
I now have a number of vlans and different subnets and grouped my devices.
my NAS is in one VLAN. The Gateway
my pc is in another VLAN. The Gateway

I did have the nas in the same vlan as the pc, but then thought to move it out as it will be accessible from the internet and thought it would be safer to have it in a vlan that did not have admin access to the router.

I have intervlan routing enabled. I can see the nas and login just fine (I have firewall rules on the B20x to inhibit vlans talking and these are disabled while trying to get this problem solved)

The problem I have is trying to use minimserver and bubbleupnp server (both on the NAS) bubbleserver client on a tablet.
minimserver says its running. Bubbleupnp server sees minimserver as an active media server.
I can get the tablet on another vlan for wifi devices to connect. bubbleupnp client can log in to bubbleupnp server but I cannot see any media to play even though its there in a folder indexed by minimserver.
I spent a long time trying to get it to work and then thought to try minimwatch - an application on the pc which should allow more configuration of minimserver and rule that out as the problem
I cannot get this to connect to minimserver on the nas
minimwatch uses java and is allowed through the firewall on the pc and has an ohnet.subnet option
If I use the subnet that the pc is in, it cannot see the server (even though I’m logged in to it with that pc)
If I use the subnet that the nas is in, minimwatch says it says the subnet is not found

Maybe this is a limitation of minimwatch, I just don’t understand why it cannot see the server when I’m already connected across the vlans and logged in to the nas. My lan side routing must work ok

Then I read about problems with upnp across different networks/subnets and I’m guessing that this might be a problem I will encounter a bit further down the road.

There’s so many settings on the router (many I don’t fully understand) like the nat mappings, routing protocols, service forwarding and passthroughs, static routes, maybe somethign similar to bonjour forwarding settings but for upnp.
It feels a bit like I might have a few issues to solve and I’m not sure if any of it can be fixed by adjusting settings on the router

Is anyone aware of a useful setting that helps with upnp streaming when a nas is in one network and the player/renderer control points are in other networks?

I found this in a cisco forum for - “How DLNA Across different Subnet???”

I got this working by using “ip multicast-routing” and adding “ip pim sparse-dense-mode” under the relevant VLAN interfaces.

I did have to activate the advipservices license on my 881W. Otherwise my device does not support “ip pim”.

Is this possible on a B20x?

well I think this can be closed.
there is a limitation on minimwatch which requires it to be installed on a pc in the same subnet. so thats that bit solved and somehow I have upnp working across the subnets. my nas has no internet connection and is streaming to my tablet in a different vlan running bubbleupnp.
happy days :slight_smile:

1 Like