Update Firmware Pepwave Surf SOHO


#1

When I open a browser to Web Administration and log into the router under the System Tab Firmware I see that the router firmware version 6.0.3 No Update Available. If click on the Check Again button I get the same exact screen back stating 6.0.3 No Update Available. How do I update to 6.1.2?


#2

Hello,

6.1.x firmware has not been yet added to our firmware server. Here is a link to our 6.1 upgrade guide along with a link for 6.1.2 firmware.

6.1 Upgrade Guide:
http://www.peplink.com/knowledgebase/firmware-6-1-upgrade-guide/

SOHO 6.1.2 Firmware Link:


#3

Thank you. I’ll just wait until the upgrade hits the firmware server.


#4

Been trying to do a manual update and keep getting a “can’t connect to the server” message


#5

Hi,

Can you provide a screen shot on this?


#6

Sorry, when I retried it to get screen shot, the update went through


#7

I still have the same problem. See attached screen shot. I tried to down load the file and cannot open the .BIN file. I do not know what I am doing wrong.




#8
  1. Download this file to your desktop or download folder
    http://www.peplink.com/support/downl…d-user-manual/
    2.In your dashboard, click “choose file”. Find the file you downloaded, highlight it and click OK
  2. When the file appears in the “no file chosen” box—it may take a few seconds, click on “manual upgrade” and let it do its thing

#9

The link provide takes me to Peplink home page


#10

is the file name fw-surf_soho-6.1.0-build1419.bin? I put this file in choose file? A . BIN file?


#11

No- its 6.12
http://www.peplink.com/support/downloads/surf-firmware-and-user-manual/
Download :
Download Firmware 6.1.2 for:

Surf SOHO


#12

Hi,

Please download firmware for Surf Soho 6.1.2 at here.

Our firmware file format is *.bin.


#13

Thanks to all who help. Now that I understand the .BIN extension I down loaded 6.1.2 and it worked perfectly. I was never down and out in that the old firmware still worked but now one of my most valuable electronic tools is now current. I’m a work camper and several of us depend on my air card and the Surf Solo. I and my fellow work campers are now more “happy campers”. When I first bought this Surf Solo I had no idea what a fine product I was obtaining.