Unlimitedville stuck on 3G?

I have a Max BR1 Mini (original, not LTE-A), and one of the SIMs in it is Verizon via Unlimitedville. It worked fine for a while, but now will only connect via 3G. Things I’ve tried:

Putting SIM in a MoFi and it connected fine to LTE.
Putting a t-mobile SIM in the BR1-mini: connects fine to 4G
Forcing to LTE-only: no connection
Rebooting the BR1-mini
Resetting the BR1-mini to factory defaults
Traveling to other regions (has persisted across 5 states and 3 timezones now)

Any ideas? The settings are basically all default/auto, which worked before. The APN is auto-setting to “VZWINTERNET”

Please open a support ticket for support team to check.

https://contact.peplink.com/secure/create-support-ticket.html

1 Like

Verizon has several Unlimited plan options now and each one of them is governed under different network and traffic management policies, all of the FAQ’s on their site explain this in more detail.

The thing is that Broadband Routers require their own ‘Connected Device’ plan and they start at $20/month for 2GB all the way up to $710/month for 100GB:
https://www.verizonwireless.com/plans/connected-device-plans/

Thanks

1 Like