UML295 speed capped on USB connection


#1

I am starting this new thread to have Peplink investigate why my USB modem will not achieve speeds in excess of approx 7.8 mbs when connected via USB. I only recently recognized it because previously I was not able to capture a signal strong enough to bring in a faster connection.

My my question is why does this happen? Is it by design? Is there another product that will provide a faster download speed when connected to a USB modem? Has anyone else noticed this same thing?

i’ll open a new ticket.


#2

Peplink support is looking into it now. Thanks Peplink! If they can figure out what’s wrong, then I’ll probably return the Netgear because for me right now, I don’t need it. However without it, I could never have diagnosed the problem because I didn’t have another way to capture band 4. I guess I could have plugged it into a laptop, but who would have thought the Pepwave would slow it down?

Anyway, hoping to find a solution this week. I work from home.


#3

Hi,

Below is my testing.

  1. Internet <— USB modem <— Surf On The Go <— PC




  1. Internet <— Smart phone <—USB tethering— Surf On The Go <— PC




This proved that we don’t cap the throughput via USB. Suspect Netgear giving the problem. You may test with your smart phone as my test lab if needed.

Hope this help.


#4

Thanks for checking on the Suf OTG speeds, maybe my unit is defective. All I can say is I have validated two different ways that I get slower speeds when tethered versus connected wirelessly.


#5

I have had an identical issue with my At&t beam with a 7.8 mb cap on downloads (30 mb when directly connected to my computer) for six months. I believe the AC 340 (Beam) is also made by Netgear. I have spoken with technical support through e-mail, was sent a new Peplink SOTG firmware to try, but the result was the same. Anyone else finding the same? Anyone with the same modems who achieves faster speeds?

Thank you for posting.


#6

Hi FenderBender711 and mrblazed,

Have you using a smartphone to do tethering? This allowed us to narrow down the problem.


#7

I haven’t tried to tether via my iPhone 6s +, but mainly because I have already established that the tethering speed is slower and I will not be using a cell phone to bring in my signal although I guess that is always an option. I do have a spare Galaxy S5.

If if I get a chance tomorrow, I get it a whirl. I was considering the SOHO as a replacement, but I may just dump using the Pepwave all together. The Netgear is great it just gives me a double NAT situation and I would need to use my iPhone hotspot to game, which is fine, just a pain.


#8

Hi,

Please take note USB tethering is supported for Android phone only. You may test with your Galaxy S5.

Thank you.


#9

This will likely be my last post here on this topic. I never tried tethering the Galaxy because in my heart I knew what the result would be. Instead I decided to simply test my UML295 on a different 4G router. If I got the same results as the Pepwave, then I would know there was something wrong with the modem.

Well, i didn’t get the same results. The new 4G router is posting the speeds I should have been getting with the Pepwave SOTG. I am seeing regularly 12-14mbs download speed now.

Since this is a Peplink forum, I will not mention the brand, but I will say is was not a Peplink brand. Either my device is defective or the firmware is in need of repair. It is definitely not the modem.

My advice to anyone reading this post is to double check the speeds you are getting and make sure they match up with your expectations. For me, until I started getting band 4, it was never a problem because my speeds were in the 3-7 mbs download range.

To TK, your results from your testimony my was on a different modem. Maybe you could test on one of these two I used and if your results are similar to mine, maybe look into a firmware update.


#10

Hi,

After reviewing the forum threads, believe this maybe related to the USB tethering driver for the specific USB tethering modem.

Please proceed to open a support ticket here and this will allow us to further diagnose on the reported issue.

Thank You