UDP NAT TIMEOUT - Balance 30

#1

Hi guys,

My client have a Balance 30, and he uses a PBX for VoIP Calls.

The problem is when someone try to call him, sometimes the router reject the call, because the dynamic port in NAT is already closed.

The PBX can only re-send the register after 120sec, and I believe that the Router is with a minimal timeout applyed.

Can I adjust the UDP NAT Timeout to 150sec?

Tks

#2

Someone? Is very important.

#3

The UDP NAT Timeout is not configurable. Thanks.

#4

Hi Tim,

TKS for your asw… but, what’s the default value?
How much seconds?

Regards

#5

I did a search on this Forum and found a post with this info:
UDP Replied - 180 seconds
UDP Un-replied - 30 seconds

Thanks.

1 Like
#6

I see that too … but I never seem replied/ unreplied

Just Timeout and end point…

Can you know in what case means wich One?

The PBX send a registrar to server, and 120sec after, again…

Att

#7

Hello, is that true? (UDP Replied - 180 seconds
UDP Un-replied - 30 seconds)
What happens to sessions which live longer than the timeouts?

Thanks
Dana

Pepwave Surf SOHO UDP session timeout
#8

Hi Dana,

Tks… but my client don’t use Peplink anymore.
But que timeout of SIP don’t send requests after a minimum of 120s… but we
change for Cisco.

Tks

#9

Don’t thinks the PBX for VoIP calls issue are fully descried in the earlier post.

UDP NAT timeout it’s more to the standard value defined for NAT device:

UDP session 30 seconds
UDP established/streaming session 180 seconds
UDP SIP 5060 session 3600 seconds.

The timeout value will keep refreshed back to the default value when traffics is sent via the sessions.Sessions will only being drop/remove when no activity for the session after the timeout value and normally this will happen if the sessions is no longer being used.

Regarding to the VOIP phone issue, i strongly believe the issue is more to the PBX/SIP/VoiP phone configuration issue whereby most of the system should defined with NAT keepalive to refresh the standard session timeouts more than changing the NAT timeout for the NAT devices. You can find some of the related info using the URL below:

1 Like
Default UDP timeout for Pepwave
#10

Hi Sitloongs,

The thing is, when the client make no more calls in 120s after the
Register with a NAT port, in the time that need an incoming call, the nat
port is closed, and the call cannot be complete.

When we change the router, no more issue happends.

The same think happends on Juniper that have his default on 60s Nat
timeout UDP, but is possible to change, Peplink no.

Tks again.

#11

Sorry as i missed this forum post. Can you please open a support ticket here for us to further confirm the issue ?

1 Like
#12

Hi all,

I realize this topic is coming up on two years old, but, as of the recent release of firmware revision 8 on the Balance series, it doesn’t appear to have been addressed.

We’ve recently been hitting brick walls with using Asterisk IP solutions (cloud-based) with Balance series devices. This is due to the same inabilities of the appliance to handle some basic configurations.

It appears that Peplink software has a hard-coded default value of 30 seconds per UDP session, 180 seconds on the UDP established/streaming session, and 3600 seconds per SIP 5060 session. The main issue is that the SIP 5060 session needs to be able to have its default value changed to 180 seconds.

This is a significant issue for us as a reseller of Balance (and other Peplink) products as we have more and more clients moving to Asterisk/FreePBX IP voice systems. Just in the last week I’ve had to send a tech to swap out a Balance One Core with a competitor’s unit (one of which was in place for less than a week). I’m not a big player in the Peplink world, but we have roughly 60 units in play at client locations now, and I really don’t like the idea of having to start pulling Balance units out and putting FortiGate units in.

It was recommended to me that I post to this thread to see if we can get software engineering to at least look into addressing this so that I can make an intelligent decision on whether we need to start pulling Balance units (and stop recommending them altogether).

I appreciate your response in advance.

Thank you,
Ben

1 Like
#13

Sounds Serious. @sitloongs do you think this can be escalated please?

#14

@MartinLangmaid

Definitely yes.

@affinitytech

Just to confirm you need SIP 5060 as below:
Session timeout 180 seconds ?

1 Like
#15

Thank you for the response. Permit me to be clearer here. By line item, these are the specifics required for optimal functionality with Asterisk:

UDP Session: 30 Seconds

UDP Established/Streaming Session: 180 Seconds

UDP SIP 5060 Session: 3600 Seconds

I think I may have had this goofed up previously. But the SIP 5060 session setting for UDP is what is causing the bulk of the problem and requiring multiple scheduled reboots daily for clients on Balance units.

Thanks!

Ben

#16

@affinitytech

image

The above is the default value for Peplink device now and suppose it’s running optimal functionality with Asterisk ?

1 Like
#17

Sorry. Are you asking me if the above is the default value or if those would be ideal values?

#18

@affinitytech

I’m checking the ideal values to run Asterisk IP solutions (cloud-based) so that we can work something on that …:blush::blush:

1 Like
#19

Roger that. Thanks for the clarification.

Actually, I had to have a tech pull that Balance One device to get the client’s phone system going (replaced with a FortiGate 60E). They were getting pretty fussy, and I couldn’t work around it with the Balance settings.

Those numbers above are what we’d need the ability to set on the Balance in order to satisfy the Asterisk’s neediness.

Thanks!
Ben

#20

@affinitytech

image

The above are the values that default running for Balance now. It should matched to the ideal settings for Asterisk’s.

You still have problem for the your Phone system ? If yes, don’t think it’s related to the UDP NAT timeout issue.

Would you please open a support ticket for support team to check from the Balance device ?
https://ticket.peplink.com/ticket/new

2 Likes