UDP Forwarding


#1

I just purchased a spa-112 VoIP-ATA. Spend 2 days messing with it to finally figure out it won’t route pasted the local subnet. eg: 172.x.x.x is it’s local IP so it wont talk to things like 8.8.8.8 (google DNS) My quick fix was to setup a UDP forwarding proxy on one of my machines.

So my question/request.

We have custom forwarding in pep-link balance one for TCP. Any way of doing a UDP proxy? Can one be added?


#2

Hi Michael,

Please refer here for the Cisco documentation based on my google result. The ATA should able to connect to the internet with default settings if internet connection is ready there. You may need to check with Cisco in the detail settings.


#3

See this is the problem.

For some reason the spa-112 won’t go outside it’s own subnet.

So the device has a 172.29.0.9/255.255.254.0 address. It can access anything on 172.29.[0-1].* no problem but the NTP and SIP servers no luck because they’re outside the 172.29.[0-1].* subnet. Basically looks like a bug to me. Contacted Cisco and long story short basically got a run around that lead no where.

I can work around the issue by setting up a UPD proxy on one of my servers. So instead of 8.8.8.8 for a DNS for example use 172.29.0.6… and for NTP use 172.29.0.20 (location of my UPD proxy). Thing is want to do it via the peplink router so I have less points of failure. (eg if the peplink is down so is the internet)

So what would be nice is something similar to your “Custom Service Forwarding Setup” just for UDP. Which makes things useful for other things… like NTP where I can point everything to the router and have it forward to and outside NTP server… (just for example)


#4

Hi Michael,

No plan to implement UDP Forwarding at the moment. Anyway, I will move this to Feature Request for the production team to take consideration and others user to join this discussion.

Thank you.


#5

Are you updated to the latest 1.4.1 firmware on SPA? I use these all over the country programmed as an extension for VoIP for overhead paging and have no problems at all. I don’t know what your using it for but I would at the bare minimum update to 1.4.1.