Trying to get pepwave to work with NAS

Not sure if got this in the right category or not but anyway…

Is there someone on the forum that can help me get my Pepwave SOHO surf to work with my NAS?

My set up is as follows:

USB cell modem (supplies internet) in Pepwave -> Pepwave to a Velop mesh via ethernet -> NAS connected to Velop via ethernet - NAS working on the Velop network.

What I want to do is be able to connect to the NAS via internet, but the Synology NAS software’s auto-set up give error message since there are effectively TWO networks between it and the internet. I want to be able to “pass through” the Pepwave like it was not there so that the NAS can stay on the Velop network and its software can then set it all up. I tried setting the Pepwave up to UPnP but that did not solve the error.

Suggestions on how to do this?

Thanks in advance.
BJ

Use an outbound policy to force the NAS to one WAN link. That will take the multi-wan issue out of it. If they host a dynamic DNS type of service for the NAS (updated by a web request from the NAS to their web service) - you might need to get creative to be able to access it from either WAN (add a second dynamic DNS for WAN2)

@mobile

Are you using Synology Quickconnect ? If yes , no inbound access required.

If you setup direct access via WAN to the NAS, first things to check is whether your USB Cell modem having public IP for such setup ?

1 Like

thanks for both replies. Re: jmjones - you are way over my head with that answer…
Re: sitloongs - I was trying to avoid relying on synology for the access… so, no, was not going to use quick-connect.

The NAS is hard ethernet wired to the Velop… I thought that would be a LAN, vs. a WAN?

I’m willing to learn here, but I’m afraid we’ll have to start on a little more basic level.
Be happy to provide any additional information/screenshots, etc.

Thanks

I believe your Velop access points are essentially acting as a second router. What’s your router’s IP address and what’s your NAS’s IP?
Also, if you go to Status > Client list on the Peplink, is the NAS in the list?

1 Like

Hi jason,
NAS is not on the client list (see pic)
Router IP is different than Velop; router 192.168.50.x, Velop 192.168.1.x
Yes, I agree Velop is second router I think.
image
The OBI is direct ethernet to the Pepwave; the user-HP is getting WIFI from Pep (susposed to be using Velop… I just never bothered to turn off the pep wifi) and the linksys is the Velop.

Ah, yep. That’s your problem.
I’m not familiar with the Velop line, but there may be a option to put them in AP only mode.

1 Like

You need to change the Velop to bridge mode.

Right now you have a velop network with NAT to the SOHO lan, which has NAT to the internet (so two networks). In bridge mode it will be one NAT network.

1 Like

Yeah, I was aware that was an option but if I do that then I lose the extra functions of the velop (parental controls, device prioritization, etc.)

That’s why I’d rather make the pepwave the bridge and Velop the network.

I don’t have a SOHO in front of me to check, but the wired WAN has a tickbox for IP passthrough - does the mobile WAN have it too?

If so you could passthrough the USB IP to the Velop gateway and make the soho transparent (assuming there is nothing else connected to the SOHO apart from the Velop).

1 Like

I see the IP passthrough in the WAN settings but there is not on in the USB settings