Trouble with WiFi handoff on AP One Mini

What is the best way to set up an AP One Mini (v3.7.0) with a Pepwave SOHO MK3 (v8.0.1)?

I am having an issue in certain areas of my house where I lose my internet connection even though I am still connected to my WiFi network. I am using the same SSID and password for the Mini and SOHO. My hack-y workaround has been to turn off WiFi on my device (i.e. iPhone) for a few seconds and turn it back on. After a few tries, I am able to get connection to the internet again.

I am using the web interface with these settings:

AP One Mini:

  • Operating Mode
    • Bridge Mode
  • WAN Settings:
    • DHCP
    • Routing Mode: NAT
    • DNS Servers: (Points to my SOHO IP address)

Please forgive the newbie-ish question as I’m not much of an expert when it comes to networking. Thanks in advance.

To add to this, using a simple WiFi test app (Net Analyzer on iOS) I can see the handoff occurring promptly between the SOHO and AP. It takes minutes though (w/o user intervention) before I get an IP address and can ping the router.

Any ideas?

Router:
10.38.10.1
DHCP Range: 10.38.10.10 - 10.38.10.100

AP LAN:
10.38.10.3
(currently set as static IP)

AP WAN:
10.38.10.4
(currently set as static IP)

1 Like

Hi cccp23,

The issue you are suffering is not expected.
Could you open a support ticket for us to take a closer look on your devices?

Thanks,
Lewis

1 Like

I have the same hardware (AP One Mini connected to Surf SOHO mk3 over powerline ethernet), with same configuration and I have the same problem: when moving my iphone, ipad or macbook pro it takes about 2 minutes to re-establish internet connectivity when joining the AP One. I will be interested in the response from support.

1 Like

Support ticket created (9110412). Thank you for looking into this.

We confirmed that issue would happen on Soho MK3 when there are any of its LAN ports configured as Access Port. We are working on the fix.
Meanwhile, the issue could be avoided by configuring all Soho MK3’s LAN ports as Trunk-Any.

3 Likes

Thanks for the workaround, which does solve my wifi roaming problem with the AP one mini. Please let me know when the fix is available for the SURF SOHO, as I would like to re-establish my port-based VLANs in the router.

May you have a try of 8.0.2s005 on your Soho MK3 to see if it can help in your deployment?
https://download.peplink.com/firmware/br1ac/fw-max_br1mk2_hotspot_sohomk3-8.0.2s005-build1482.bin

Thanks,
Lewis

1 Like

I am posting this in hopes it may help others using the Surf Soho MK3 who have wifi handoff issues.

My Pepwave Soho MK3 serves as both a router and an AP. I also have a Pepwave AP One Rugged (for coverage in a different part of the building) which just relays IP addresses from the Soho (which serves as the DHCP server).

Without a VLAN enabled and port assigned as “access”, the iOS devices handoff between APs perfectly upon leaving signal range. However, with a VLAN enabled and port assigned as “access”, the iOS devices that go out of range of the Soho will connect to the Rugged AP but drop the DHCP relayed IP address. The iOS device will then self-assign an internal IP number (i.e. 169.254.xxx.xxx) about 6 times over the course of ten minutes before finally obtaining its correct original IP address relayed from the Soho DHCP server through the AP One Rugged, once again establishing network/internet access.

The workaround for this issue is to disable VLANs with ports assigned as “access” (it’s possible that ports assigned as “trunk” may be OK).

The actual fix is available in beta firmware 8.0.2s005, and Pepwave support messaged me today that it will be included in the next G.A. firmware.

3 Likes