Trouble using Starlink as WAN in Balance 20X

Finally got my Starlink terminal, which is why I had gotten my B20X a while ago. Because of the reputation for drops, I wanted SPC for working remotely (lots of video calls). Until Starlink got here, I was using two cellular connections - the first was as AT&T home internet box (plus telephone jack) that had an RJ-45 out. That was plugged into the WAN port on the B20X. Then I had another AT&T SIM in the B20X to be used as a hot failover. Worked like a charm. The signal is super weak here and drops frequently (was fine when they still had 3G, but those days are over). The B20X worked like a champ since it seems both SIMs (the one in the AT&T home internet device and the one in the B20X) would not lose their signal at the same time.

Now that I got Starlink, I got it set up, and get great speeds with the cable coming from the starlink router (I have the ethernet adaptor). But when I plug that cable into the WAN port, I don’t get those speeds. I get something, but essentially all the traffic goes to the AT&T SIM. I have connection type set up as DHCP since that was what worked with the AT&T internet device.

On the Dashboard, I get the WAN failing health test all the time, as well as an additional message at the bottoms saying

“Failed to receive DNS response from the health-check DNS servers for WAN. But public DNS server lookup test via the WAN passed. So please check the DNS server settings.”

I searched here and there posts about DNS health check problems and people recommend checking off “use public servers” under the WAN, but all the suggestions didn’t help.

The one other wrinkle in my set up is that I have a ubiquiti nanobeam sending the Starlink signal from my clear-view-of-sky area to my house. However, that seems to be working well. I tested it out computer-to-computer on a local LAN before switching it over to WAN. And again, if I plug a computer straight into the cable from the house nanobeam, I get a connection and great speeds.

I have not set my starlink router into bypass mode so I am mutliple-NATed but I don’t think that should cause this problem.

Do you have internet in front of the 20x ? You could also try changing to ping test.

1 Like

Yes, Internet in front of the 20x. Actually right now, I have the ethernet cable plugged into a laptop that I am using for a hotspot to provide wifi to this computer to type this.

I tried changing to the ping test, but got the same thing. When the box runs the health test, it fails. Then it reconnects until it runs the test again.

There were a few times when I tried to load a web page at (accidently) just the right time and the page loaded very fast. But those are just brief windows between the down times.

Thanks for replying.

Does it stay connected if you disable the health check?

1 Like

Have you read the recent Starlink threads. There is a known issue with a work around. What happens when you plug your starlink into a switch and then the port on the peplink?

1 Like

Yes, but mostly no. Let me explain. I turned Network Check to disabled. It stayed as “connected” on the dashboard. I ran a bunch of speed tests using google speed test. I repeated got very high speeds on download (after an extended wait each time while contacting the server) but upload timed out each time. I returned to this page to type my reply and when I clicked “reply” nothing happened. I tried loading some other webpages and they partially loaded fast, but not all the way. So mostly no.

I am back now with the ethernet cable plugged into a laptop serving as an access point, and have fast internet. But of course there are a number of reasons I bought the 20x, besides the SFC hot failover, so would like to figure out how to get this working.

I realize I have a complicated set up right now with the signal going Starlink ethernet adaptor > pair of nanobeams > the afore-mentioned cable I am plugging different places. But I am sure the nanobeams are setup correctly to act as a virtual ethernet cable (I tested extensively running it on the LAN and transferring files between computers). I have not set the Starlink router into bypass mode yet because the only way to go back after that is a factory reset (!) and would like to have access to the terminal in the dish for a while more before having to work with static routes and the like (trying not to change too many things at once).

I will search for Starlink threads here. I did some searching first, but only for the WAN health DNS checks.

My next suggestion would be to put a small unmanaged switch in between the upstream device and the wan port of the 20x.

1 Like

Probably this one right?

Looks like I need to pick up a cheap switch. All mine are in use right now.

@J_S, would you mind submitting a ticket here with your B20X S/N, Remote Assistance = ON, a sketch of connectivity diagram to allow us to take a closer look at the router?

So far, we have seen MAX Transit (Transit, Transit Duo, Transit Pro E) and Balance One (B1, B1 Core) with this symptom. Not too sure B20X would experience the same with the Starlink Gen 2 + Ethernet Adapter (in Bypass mode) setup. Do share the ticket number once you have it submitted.


WeiMing: Thanks for offering to look into this. I propose the following: I need to use today the temporary setup I have now (using a laptop as an access point), but I do have a new switch being delivered tomorrow to test that possible solution. I will set up the switch when it arrives. If that solves the problem, I will still open up a ticket for you to take a look. If it doesn’t solve the problem, I can still plug the laptop into another port on the switch to provide me with the bandwidth I need to continue working.

Please note that I have not yet set Starlink to Bypass mode, as once I do that, I lose the ability to adjust terminal (i.e. the “dish”) settings until I get static routes set up in a router. I don’t think that presents a problem other than double NAT. Don’t know if it is an issue with both the Starlink router and the 20X having a DHCP server, but before I got the Starlink, my “WAN” feed was also a router (this AT&T modem/router: At&t IFWA-40 User Manual that had a DCHP server running, and it worked just plugging it into the WAN port on the 20X.

Just an update - delivery of the switch is now scheduled for Saturday (eastern US), so I will submit the ticket on that day.

WeiMing: I created ticket #22061138. Placing an unmanaged swtich before the 20X did not solve the problem. I enabled remote assistance and attached a connectivity diagram.

Thanks for looking into this.

I have issues with STarlink after the latest firmware update I have to put a unmanaged switch between starlink and the peplink 20x it works but that is extra power I don’t want to have on my UPS. Are others running custom firmware or using 8.2.1 ?

I put this unmanaged switch between Starlink and the 20X: (TP Link TL-SG105 5-port gigabit swtich). It did not fix the problem. I am running firmware 8.2.0.

I’m working with @J_S for the issue and look like there is network/IP overlapping/conflicting between LAN & WAN networks and this cause the connection unstable.

Sit Loongs solved my problem. Because I have not yet put the starlink power brick/router into bypass mode, its hardwired IP of was conflicting with the default same IP of the 20X. I changed the IP of the 20X (to and now it works. Changed the DCHP range to match as well.


Ahh I see I am running in bypass mode. Glad you figured it out.