Trouble communicating with a switch across VLANs


#1

I’m having trouble getting my managed switch (Zyxel GS1900HP) to connect to my Pepwave SOHO across VLANs. I suspect it’s due to a setup issue on my switch but I wanted to ask here to doublecheck that I’m not overlooking anything. I only just got my SOHO last week and am still learning the ropes.

I can connect to the switch w/ no issues when on the same VLAN:

Pepwave SOHO (10.38.10.1, VLAN 1)
Zyxel Switch (10.38.10.2, VLAN 1)

Now when I try to assign my switch to a separate VLAN, this is where I’m having trouble:

Pepwave SOHO (10.38.10.1, VLAN 1)
Zyxel Switch (10.38.30.2, VLAN 3)
NVR (10.38.30.10, VLAN 3, connected to port 2 on the SOHO)

I have the Port Type set to Trunk on the SOHO with the comparable setting enabled on the switch as well. Inter-VLAN routing is enabled on VLAN 3 on the SOHO. I can ping the NVR from VLAN 1 so I know that Inter-VLAN communication works. However, I can’t for the life of me ping the switch from the SOHO or vice-versa. I can see the MAC address of the SOHO from the switch so it is connected but something with the IP assignments seem to be amiss. I don’t have any other devices with the 10.38.30.2 address.

I’m guessing that my VLAN settings on the switch are to blame but I’ve not been able to track down the issue. Anyone have any ideas?

Thanks in advance.


#2

Hi cccp23, why you create a interface vlan3 on the switch ?
you can set the peplink port in trunk mode, and the uplink of switch in untagged for vlan1 and tagged for vlan 3, than tag the nvr port with vlan3 .


#3

Thanks for the reply.

So are you saying I should keep the switch on the 10.38.10.1 subnet (VLAN 1) and simply set the VLAN tags as you describe?

To clarify, I have these devices connected to the switch:
Port 1: SOHO
Port 2: PC
Port 3-8: IP Cameras

The IP cams will be on VLAN 3 and the PC on VLAN 1.


#4

Hi This should be the port configs to get the VLANs flowing;
-Surf SOHO - Port connected to switch - Port Type - Trunk, VLAN - ANY
-Zyxel Port Connected to Surf SOHO - PVID - 1, Accepted Types - All, VLAN Trunk - Enable
-Zyxel Port Connected to CCTV - PVID - 3, Accepted Types - Untagged Only, VLAN Trunk - Disabled

Simply put, the link between the Pepwave and router should be a “VLAN Trunk” and the connection to the CCTV should be an “Access Port”

Hope this helps


#5

Hi @cccp23 , yes need to configure the switch with an ip of vlan1 (10.38.10.1),

The switch port that is connect to peplink you need configure untagged vlan 1 and tagged vlan3.
The switch port of pc, set untagged to vlan 1
The switch ports of IP Cam , set untagged vlan3

important that the inter-vlan is need active between the two vlan on the peplink

Regards
Antonio