T-Mobile keeps trying to obtain IP Address

Hello All
For whatever reason, my T-mobile SIM will not login to the network. APN is correct and I have full bars. I confirmed with my provider the new SIM is good to go. Anyone else seeing this lately?

This may be of limited utility, but:

  • Our TMO connections (California deployments, a handful) are connecting without problems on the plans we use (post-paid).
  • The units are CAT-4, CAT-6 and CAT-12 devices (BR1, HD2, Transit Duo)
  • Network mode is set to Auto (not generic)
  • APN is auto on all.
  • LTE/3G set to LTE
  • Some band selection has been made (removing some underperforming bands)
  • Modem firmware all up-to-date.
  • FW is 8.2.0


Good luck.

Thanks - I will try the Auto section - which bands do you find reliable? Are you able to take a snapshot? I can try to mimic that and see if that helps. My APN is very specific to b2b.static - If I do not use that, it will throttle back on my plan. Thanks! Jim

  • W.r.t. bands, we have never found the “auto” setting to fail. The (de-)selection of bands has been a matter of connection optimization (we do not always agree with the tower’s choice) and vary by location.
  • W.r.t. APN we usually leave it on auto and our plan lands it on fast.t-mobile.com. Sometimes, in cases where we had a custom SIM with a custom APN installed then we’ve had to explicitly identify fast.t-mobile.com as the APN. But that would be the exceptional case.

FWIW, I have a screenshot of settings from an HD2 CAT-6:

Very non-customized.



PS: I should have asked: Is your unit a CAT-18 model? T-Mobile does not seem to connect to those at all.

I am running the Pepwave MAX Transit
I have been running on T-Mobile for two years and then it just stopped - my provider sent me another SIM incase that was the issue.

Have you tried locking it to JUST LTE? Mine just recently started failing when 3G was still an option… I think TMo is turning 3G off and it may just be stuck with no responses from 3G towers.

Hello Michael
That did it! Well, I logged in to Band Selection - changed it to LTE, then back to Auto and that did the trick. It makes no sense to me why, but that seems to have logged me in.

1 Like