Surf SOHO won't pass Windows Remote Desktop

New to this forum, so first post.

Surf SOHO, running firmware 7.0, build 1139. Bought to replace a Cradlepoint MBR1200B to get gigabit network and 5g WiFi.

There are just two computers - a laptop running Windows 10 Pro and a home theater server running Windows 8 Pro. With the Cradlepoint, the laptop can connect to the HTPC using Remote Desktop, no problem. With the SOHO, it can’t. The SOHO shows both computers connected (Client list), each computer shows on the other in Windows Explorer under Network, and each computer can access shared drives on the other thru Windows Explorer. The folks at 3GSTore have been scratching their collective heads for a week with no success. Possibly (probably?) related is the fact that two Roku devices that can access the media server on the HTPC (Emby) when connected to the Cradlepoint cannot do so using the SOHO as the router.

Anybody have any suggestions? To get 5G wifi and gigabit speeds in a router that can use the Verizon USB modem, the choices are exteremely limited - just the SOHO.

Thanks in advance . . .


Anybody? Or do I have a $200 paperweight?


Dunno what the issue is there. I’m with the guyz @ 3GStore – can’t see why it would not work. Normally we use other means (e.g., TeamViewer), but I just tried to connect from one LAN served by a Balance 20 to another served by a Surf Soho (FW 7.0.0 in both), via PepVPN. The machine from which I was connecting was Win 7 Enterprise and the destination machine was some version of Win 10. There were no problems and the connection was snappy.

Also just connected from the Win 7 machine to another Win 7 box, a raspberry pi and an IoT device located on the same subnet behind a Balance 20. No problems encountered.

No firewall issues getting in the way?

The SOHO is an excellent product – don’t throw it away! ;<)


1 Like

Just happened to find this – I’m having the same issue. Did you ever get this figured out?

Update: I was running firmware 8.0.0 when it wasn’t working. I rebooted into 7.1.0 and it worked, then rebooted back into 8.0.0 and it’s still working for now.

It’s been so long, I’ve forgotten what happened to make it all work
again for me. But it’s been doing fine for quite a while. I’ll try
to remember the firmware tick should I ever run up against that kind
of thing again. Thanks.