Surf Soho - Why is the Connection So Slow - Help


#1

Can someone assist me in determining what’s causing my connection to be so slow?

It’s not my cable internet connection, it’s the router.

I have Content Blocking enabled to block Remote Access, Peer to Peer connections, and a few other things. I’m also blocking File Upload sites, Porn, and File Transfer sites.

I added domain exceptions that I visit regularly like YouTube, Hangouts, Vimeo, and a few other sites I frequent.

I also have intrusion detection checked.

Are any of these things causing my connection to drag? Just watching a YouTube video or doing a Hangouts video call freezes up, and makes a tone like there’s congestion or the connection is struggling with bandwidth. This happens even when I have only one tab or application running. I don’t have other things connected to the router. I’m not broadcasting the SSID, and I have a solid admin password and WiFi password. I have also disable remote access via InControl

Any help is appreciated. I am using Verizon Fios Internet into the Router - WAN - wireless.


#2

I’ve upgraded the firmware and also clicked to enable Google DNS servers. Hope this helps. Any other tips are welcome. Thanks.


#3

What is the speedtest throughput that you can get ?


#4

My internet connection became slow after upgrading to 7.1.0. I have a 75Mbps plan with my internet provider and used to get anywhere from 50 - 60+ Mbps average on 2,4ghz, but now im getting under 20Mbps with firmware 7.1.0s021-build1289 from customer support.


#5

I am having the same problem with a Surf SOHO. I’m not certain its the firmware though. If I do a speedtest (xfinity) before the router I get 60 Mbs down/30Mbs up. After the router I’m hard pressed to get 10Mbs in either direction. I’d appreciate any advice. By the looks of the dashboard, I could boot with the previous version of the firmware, but I don’t recall the speeds being any better.

I rebooted with the previous firmware, 6.3.3 and it is no better…


#6

At least for me, I believe something besides the router is the cause. I have retried the speed test throughout the day and for the most part it has been low as stated earlier. Then this afternoon, speeds jumped up and now are 75 Mbs up 26 Mbs down. So its the ISP that is governing the speed, I believe. I upgraded the firmware yesterday, so it’s the latest for the SOHO.


#7

@Aquaman & @acatalano

Mostly what we found is that the environment actually that cause the performance reduced. SOHO/SOHO MK3 router is rated as 100Mbos/120Mbps router throughput, hence you should get the speeds closer to the rated throughput. Environment influences are the things that we need to check that would possible cause the performance reduced.

Environment Influences included the followings:

  • Physical connection (Negotiate Link Speeds)
  • Ethernet connection speed-test compare to WIFI
  • WIFI AP (Especially 2.4Ghz) always affected by interference, hence the performance can be vary from time to time
  • others

@Aquaman
You mention WIFI AP 2.4Ghz performance issue

  • First, can you confirm when you use Ethernet connection what is the speeds that you will get ? Let’s us isolate the issue first.
  • Seconds, the performance tested from the same locations (device to SOHO) ? Do you try before changing the 2.4G channels ? Any different for the speeds ?
  • How about if you tested using 5Ghz, what the performance that you get ?

#8

Hey @sitloongs ,

My desktop computer is connected to the router through Ethernet and i can almost always reach over 75Mbps - average is 83Mbps.

The speedtests i have done on my 2.4 ghz devices are all infront of the router. I have tried all of the channels from 1 - 13 and found that channel 3 is most ideal as there are no other networks in my area using it. It also gives me better speeds than the rest of the other channels. See here for my 2.4ghz speedtest

Performance with the 5ghz is not an issue, i can reach well over 75Mbps. See here for my 5ghz speedtest.


#9

Just for the record, all my tests were done using a wired ethernet connection. That said the ISP connection is wireless, beamed from a distance of about a mile, line-of-sight. That’s a big environmental variable there. However the test results obtained before and and after the router still disturb me. Could just be a coincidence. I’d like to be able to conduct a test both before and after my SOHO Mk3 simultaneously to be certain. Anyway, failover works great. If I determine the culprit I’ll post it’s cause.


#10

@Aquaman, the problem you are facing is clearly related to the Wifi interference in 2.4GHz as mentioned by @sitloongs here. 2.4GHz only has 3 non-overlap channels which are 1, 6, and 11. You may read here to understand more. Looks like all channels of 2.4GHz are fully interfered in your environment. I would suggest using 5GHz.


#11

Thanks for the response @tk_liew. Not sure how to set 5GHz as the default option in the Soho, but I’ll see if I can figure it out.


#12

Hi All,
I have 150/150 mbps speeds at my house with my current ancient Actiontec MI424WR Rev F router on Verizon Fios. I’d like to use the PepWave Surf Soho MK3 but I’m concerned as it says the speeds are only 100 Mbps. does that mean it will be the bottleneck?


#13

It means you’re not even going to get the 100 it says.


#14

Hello Larry,

The max throughput for the SOHO is 120 Mbps, so you will run into a bottleneck with your 300 Mbps. The Balance One supports up to 600 Mbps or up to 400 Mbps with 5 WANs active. You can see a comparison of our Balance devices here:

Thanks,
Zach