surf SOHO refuses to connect with my modem


Hope someone can help.

I am trying to connect my surf SOHO mk3 to the internet but it refuses to work.

When I connect the ethernet cable the green and orange lights are lit. the orange light blinks but the green just stays lit.

when you go into the dashboard under wan it just says connecting and never does anything. there is also no throughput.

I have tried doing a factory reset which did not help. I have tried the following firmware:

8.0.0s167 build 1464 - this is what was installed
8.1.3 - The latest
7.1.2 build 1387 - last version in the 7 series.
my modem is a netgear nighthawk cm1200. my internet provider is wow.
My current setup (netgear router + netgear modem) work fine.
I have tried switching ethernet cables but that had no impact.
Any ideas as to what I can try now?

1 Like

Is the Netgear router your’s or ISP’s?

Have you tried power cycling the modem before connecting it to the peplink?

What ports are you connecting to on the modem and what ports on the peplink?

Have you tried a factory reset of your Peplink?

The same thing happened to me two days ago - I’m also on 8.1.3. The modem is good (verified by local ISP), and my WiFi also shows good - I Just can’t get to the internet. I assumed it was a bad WAN port and just ordered another, but it hasn’t arrived yet.

In my case (not the OP) the Netgear modem is mine.

Edited: The Surf SOHO is now working; the router wasn’t the problem. I replaced the router, the cables, and finally the modem; the modem was the problem. I now have to decide whether to return the replacement router or use it. Funny thing, the ISP told me they thought the modem was fine.