Surf Soho Random Reboots

Sorry about the dual posting, can’t figure out how to delete the incomplete first post.


We have a Surf Soho with 6.0.3 build 1257.
Using a Pantech UML295 Modem with up to date firmware on Verizon 4g network with a static IP.
WAN and WI-FI WAN are disabled.

Previously we had a problem with network disconnects with a PANTECH UML290 modem about every 72 hours, we are no longer having problems with the new modem.

However, we recently started experiencing that the router will go into a reboot every 48 hours or so. If we are present and log in to the admin page, we see that the DASHBOARD shows that changes are being applied, whereas we made no changes.

Today we experienced 4 such random reboots of the modem. Each time modem does reconnect quickly to the Verizon Network, so it is just the inconvenience of losing all network connections for 2 minutes at a time.

Also, we have noticed that each time the router reboots, the initial log entry states the same date and time regardless of the actual date:

Dec 31 18:00:49 System started
Dec 31 18:01:31 WAN: Priorty changed (Priorty1 -UML295 Modem / Disabled - WAN/Wi-Fi WAN)
Feb 04 16:06:48 System: Time synchronization successful
Feb 04 16:08:04 System: Changes applied

All in all, not a big issue, but would like to know if can prevent the random reboots, is there some setting we are not aware of.

Thanks in advance for any advice


I recommend to upgrade to firmware 6.1 first, here is a link to download it:

Thank you Tim for the fast response.

Downloaded and applied the 6.1 firmware upgrade and saw a message that it updated successfully. However, the system information and firmware pages still show version 6.0.3 build 1257.

Do you think I need to apply the upgrade again?



I got the firmware to upgrade.

I ended up registering on InControl, added this router as a device (still under warranty), enabled InControl in the router and did the firmware upgrade again. Process it took much longer but successfully upgraded.

Will monitor and see if this resolves the random reboot problem.