Surf SOHO MX3 - Poor Netflix Performance

Been running a Linksys EA3000 connected to 30Mbps Cable modem with Guest-Network with a second Linksys EA6900
connected to port 1 to create a DMZ for various smart home devices to prevent them from accessing my home computers,
fileservers, printers, etc. I have a SmartTV that connects via WiFI to the external Guest network and streams things
like Netflix, Amazon, Hulu, Youtube, etc. Its worked fine for years.

I just replaced the EA3000 with the MAX Series/Surf SOHO router. Setup an isolated VLAN, connect a couple of these
IoT devices to two of the hardwired ports, the rest connected to the Guest Wifi.

Now I’m having problems with Netflix streaming. I have the bandwidth. I regularly test my download/upload speeds
and they always exceed the 30Mbps down and 5Mbps up. Roughly this setup has worked for years with consumer
grade routers.

I’ll start watching a Netflix video and everything will be streaming fine. After 5 - 10 minutes, it will start a buffering
download. Some times it counts up to 99% and the video starts back up. Other times it sticks at 25%, hangs there
for 30-40 seconds, then errors out with message that the video isn’t currently available, try again later. If I try
to resume the video, most times it will load to 25% and hang. Some times the video will resume.

Also, NOTHING else in the house is doing anything on the internet. This is happening at 3am after everyone else
has gone to bed. I’ve checked which devices are online to make sure no one is also streaming or web surfing.

Signal strength of the TV is -73 dBm.

Any thoughts on what’s causing this and how to improve it. Note that I’m not using an secondary Wans. My first attempt I tried setting up my neighbors Wiifi as a secondary WAN (with his knowledge). Had problems. Then I read on the
forums that scanning for Wifi networks was causing a 10% packet loss.

You only mentioned Netflix streaming so I can only assume that Amazon, Hulu, Youtube are all fine? The SOHO does not care what sites you go to and its job is to just route packets. When these packets leave the SOHO and go out on the wire we have no control.

To rule out a Wi-Fi issue you could temporarily connect the Smart TV via Ethernet and see how you make out. You could even bypass the SOHO all together and go TV to cable modem. Then if you still have the same issues you have a legitimate complaint you can bring to your ISP.


1 Like

I’ve been doing this for 4 years since I bought this TV. It use to connect wirelessly to a Linksys EA3000 that I’m replacing to have a more secure network. It worked with very little trouble with the EA3000. There was occasional buffering, but
it always recovered. Didn’t timeout and claim the video wasn’t available.

I need to check youtube and Amazon to see if there are similar issues.

How can I check for dropped packets? There are several posts that says when this router is scanning for a WiFi WAN it drops 10% of its packets. I originally had plans to use my neighbors Wifi as a backup network and he was going to use
mine. I’ve dropped that idea for the moment.

Just be sure WiFi WAN is disabled if your not connected to a WAN network. The issue arises when its enabled but not connected to anything, it will say “Scanning” with a spinner.

You can see the issue with a program like Pingplotter, which is a good tool for diagnosing connection problems in general. I can open ping plotter and just ping the router ip and get 10% packet loss to it if WiFi WAN is enabled but not connected to any WiFi network.

Note it has to be on the same frequency too, if you have WiFi wan enabled on 2.4GHZ but are connected to the router at 5GHZ you won’t see the issue. So its easy to get into a situation where your laptop is connected at 5GHZ and see no issue but your smart TV is connected at 2.4 and is suffering from it. The SOHO has two separate radios, 2.4 and 5ghz so they do operate independently, but LAN WiFi on the same radio as WiFi WAN will not work at the same time if its doing a scan which it does every few seconds when looking for networks causing the packet loss on LAN.



The TV was connecting to the 2GHz band because the signal was strong. I turned off the 2Ghz radio to force the TV to connect to the 5Ghz signal, but then my Ecobee 3 thermostat stopped working. Apparently it only works on 2Ghz. Solution was to create two guest VLANs, one wit only 2Ghz, the other with only 5Ghz.

Netflix streaming smoothly now.


Thank you so much for this comment. The “Scanning” spinner on one of my WAN WiFi’s was the exact cause of my xbox streaming problem. Plus, I’d bet it was causing problems with my work laptop, specifically Skype.


Glad it helped, was frustrating to track down when I originally got my SOHO since this behavior is not documented anywhere and the WiFi WAN feature is promoted as being pretty much seamless.

I really think if they are not going to change the firmware they at least need to make it much more clear that wifi WAN enabled but not connected to any network pretty much makes LAN on the same frequency unusable.

1 Like