Surf SOHO MK3 WiFi trouble since upgrading to firmware 8.0.2 build 1480

I’ve had WiFi trouble with my Surf SOHO MK3 since upgrading to firmware 8.0.2 build 1480.

I’m looking for advice on what to check out, but first, here’s description of the problem:

Prior to upgrading the firmware (which I did at the beginning of this month) my router “uptime” was well over 200 days, but in the roughly three weeks since the update, I’ve had to reboot my router several times because of the WiFi degrading, and I’ve not been hasty in rebooting it. For example, the most recent time, I waited over 24 hours to see if it improved on its own (just in case the problem was RF interference rather than the router).

My problem could have nothing to do with the new firmware version, but the timing seems suspicious.

Worth mentioning: before a recent episode where I had to reboot the router, on my Mac Book, WiFi was unusable when connected to my router, and the problem persisted across reboots of the Mac Book. However, at the same time this was going on, my phone was performing just fine, and I was certainly connecting to my own router. I know that because I made sure to turn off mobile network access on the phone, and my phone doesn’t have the password for any other WiFi access point in the neighborhood. I’m guessing the Mac Book and phone were attached to different frequency bands (i.e. one to 2.4GHz and the other one 5GHz) but I wish I’d thought to check that. I suppose it could also be a protocol issue, where the phone’s implementation successfully deals with some problem the router develops.

What should I be checking the next time this happens?

There are so many possible problems with WiFi, hard to know where to begin. I would create an SSID that is only on the 2.4ghz band and another SSID that is only on the 5ghz band as starters. If the router is picking channels automatically, rebooting may result in a different channel. Do you have any type of WiFi scanner that will help you pick relatively free channels? On Windows, WifiAnalyzer from is great. On Android, there are many similar apps.

Just curious, what firmware were you using when the Wifi was good?

1 Like

Hey. Home user here. I have a SURF SOHO MK3 and have always had connectivity problems with my apple ipads/ iphones after upgrading the firmware. I found that after upgrading the firmware, doing a factory reset and then reconfiguring from scratch would always solve the problem.

Sidenote: I believe I traced the problem to the Client Signal Strength Threshold on the AP page under SETTINGS. It should be set to 0 - 10 (-85db) to easily allow clients to connect initially. I suspect that setting may get corrupted on upgrade but haven’t fully tested that hypothesis. I usually have it up around 50 (-45db).

If at that point you are still having connectivity problems I would check the AP menu, SETTINGS and set CHANNEL to AUTO. That way if its a noisy crowded WiFi neighborhood the SURF will hop around to clear channels automatically.

Like Michael234 said you could also use a WiFi analyzer to see if the SURF is broadcasting your networks and to check how congested the airwaves are. Look for an unused or less busy channel in the 5Ghz spectrum.

Lastly and this is a long shot but I found that iphones and ipads (ios 12-13) will share WiFi network passwords amongst themselves if Bluetooth is turned on (not sure about mac books) and connect to WiFi networks in your contact list. The feature is called “Family Sharing” and I believe is rolled into Bluetooth file sharing, airdrop, handoff, and carplay. Under general settings on your iPhone you could turn those features off in addition to turning off Bluetooth when not in use.

Bear in mind there is no specific user setting for “family sharing” its just built into those Bluetooth services. Sometimes this will piss off the router or client if you have really high security settings like MACS whitelisted or really tiny 1 or 2 slot subnets. Again this is a real longshot but I saw it on the SURF’s STATUS, CLIENT LIST page and verified with KISMET when I was monitoring my VLANS and thought it was pretty funny / concerning from a security standpoint. ie: I had created multiple WiFi networks / VLANS to isolate different clients and they all started jumping over to other networks with no apparent explanation completely defeating the purpose of isolated VLANS. Family sharing is not a feature I wanted nor asked for. Turning Bluetooth and associated services off solved it.

Since bluetooth might share the same 2.4Ghz radio as WiFi in addition to unwanted features like “family sharing” I just turn it off during initial connection attempts. Then reset the iPhone or ipad’s network settings and just create a new network / password and it was good to go. This is where the SURF really shines as that is so easy to do and you can isolate devices on their own VLAN / network so it doesn’t interrupt other users networks. One feature I really like about the SURF is that changing 2.4Ghz network settings and saving the changes does not interfere with the 5Ghz networks and vice versa. Comes in handy for testing things without interrupting other users.

One other funny thing I saw with the iPads/iPhones: my wife would often have up to 25 windows / applications open on her iPad and it would not connect to a new network because it was basically out of RAM at that point. At the time I did not know you could double click the home key to show all the open applications - so I couldn’t figure out why it wouldn’t connect. Close all apps and / or reboot the ipad/iphone before attempting to connect to a network if you are having problems. To save time and avoid frustration, attempt initial connections with a small easy to type password to verify that it works before investing the time it takes to pound out 45 digit passwords multiple times on the error prone ipad/iPhone ghosted multi-keyboard interface.


I’ve been running my soho since November. I found the wifi wasn’t the greatest at first. (Before 8.0.2)

I have 4 iPhones and 2 iPads, 2 chrome books and another Linux laptop. A few iot devices (no google or Alexa crap) Everything else is hardwired.

My idea was to limit as much as possible what I have running on WIFI. The more I can hardwire the better, less wifi traffic is a win. (I have roughly 40 other nearby networks at various signal strengths however, but that’s out of my control)

What I did which seems to have helped is I segregated my IoT devices into their own vlan and disabled the 5Ghz band, since all of them only support 2.4. Channel width set to 20mghz and auto channel selection.

My main devices (iOS, laptops etc) run on main lan with 5ghz only band enabled. More room to maneuver there and much less crowded. Channel selection is auto and width set to 20/40mghz.

My main devices don’t have to switch frequencies, the 5ghz band is strong enough to cover most of my home. (Worse signal strength I get is -75-80)

I’ve this configuration to work best. No complaints. I think there might have been an issue with iOS devices latching on to 2.4 band a lot and causing an issue when flipping to 5ghz band.

My $0.02


Thanks for all of this information, and suggestions.

I took Michael234’s advice and set up separate 2.4 and 5GHz networks, and I’m about to play with a WiFi analyzer. My neighborhood has around 15 networks that the Mac Book can pick up. So, it’s crowded, but not like near a dense city thoroughfare.

My prior version of the firmware was probably 8.01 but I’m not 100% certain. But I bought the router in early 2017, and I’m the type of person who does update firmware on devices, and I’ve definitely done it on this device before.

happysurfer, that’s an interesting story about the “family sharing” feature. I hate that stuff!

My Client Signal Strength Threshold is set to zero, though “-95 dBm” is also written next to it as well as “0: Unlimited”

1 Like

Oh there was one other thing…

The last few firmwares I tested supported*:

  • 7 x 2.4 Ghz WiFi networks
  • 7 x 5 Ghz WiFi networks.

This revision supports**:

  • 7 x 2.4 Ghz
  • 15 x 5 Ghz

*As tested on my SURF MK3.

**A great improvement / keeps getting better.

1 Like

Just reporting in that I have been having the exact same issue with the exact same router ever since I upgraded. I went back to my old firmware. I think I’ll just wait until the next one comes out and try again.

For what it’s worth, here’s my followup (four months later): I’m on the same firmware as I was in January. I haven’t had to reboot the router more than a few times since making 2.4GHz and 5GHz networks. When my device connection seems to be having trouble, I make my device connect to the network in the other band (whichever one I’m not currently using) and it seems OK. I’m not sure how often I need to do this. Probably once a week, maybe three times some weeks, but it’s worth noting, I’ve always had some amount of transient interference here, so the need for some of these band switches may be about that, rather than about the network going into a degraded and unrecoverable state, as it seemed to be doing in January, when I only had one network spanning both bands.

How has this problem not been address from Peplink? We have hundreds of Peplink SOHO routers that we manage and are seeing very similar problems.

@Michael234 provided a good suggestion here.

Separating the SSID with different Wifi Radio helps to isolate the problem whether it happens in 2.4GHz only or 5GHz only. You may need to take note on the Wifi interference and the signal strength receives by the Wifi client (-70dBm and above is recommended. Please refer here)

1 Like

None of the recommended solutions have fixed the problem. This problem is Peplink hardware/software related. We have started decommissioning routers from production over this issue. We need a solution to this problem.


Do you have ticket opened for the problem ? If yes, would you able to share the ticket number here ? The best is allow support team to check on the devices to confirm the issue.

1 Like

My iPhone 8 plus seemed to lose WIFI connectivity at some point. I believe there is a known bug or flaw in IOS 13.x (possibly back to 12.x)… are the disconnects solely happening with Apple devices?

I have since disabled band steering on my 5GHZ network where my iOS devices connect, after reading on a few forums this was possibly causing wifi reconnects for iOS devices. Although having band steering enabled on a 5ghz only network is useless anyways, no harm in disabling.

I have also tightened up my channel width on the 5ghz to 20mghz and chose channel 165. No other network in my area is using that channel, since most routers will use a wider channel and channel 165 is only used when 20mghz channel width is used. Slight drop in speed with narrower channel, but nothing noticeable in actual usage scenarios. (10-15% drop?)

I’d like to say it’s been pretty “stable” since then.


I’ve had issues with maintaining an internet connection with my Surf Soho router after upgrading the firmware to version 8. At first I could downgrade to FW 7 and have a stable connection, but after I upgraded to FW 8.1 I lost the ability to downgrade to 7 and am stuck with continual internet disconnects that require resetting the router. Did extensive troubleshooting with the router and modem: checked modem + router logs, replaced the modem, factory reset the router, etc. with no improvement. Finally replaced the Surf with an ASUS router which solved my connectivity problem. What sold me on Peplink initially were all of the safety and security features built in to it (compared with generic consumer routers), but in the end, it must stay connected to the internet for these to be relevant. I spent too much time troubleshooting this problem, mostly because I wanted to believe Peplink would deliver a consumer product with greater than 2-3 years use for my $200.

Is that situation still true with FW 8.1.1? We have a number of SOHOs in use with our customers and they do not report this situation with the current FW.

And, I should also note that Peplink is the only manufacturer I know of which will involve high level technical support in such matters – including remote assistance. If you want to pursue this it’s a simple matter to enter a support ticket – assuming your seller is unable to help.

Hello Rick,

Yes the situation is still true with my SOHO router. I know not all SOHOs are affected the same; I have 3 of them in different environments and they have all behaved differently. One of them has not had any issues upgrading to FW 8 at all. The other 2 started disconnecting with the first FW 8 and both had to be downgraded to 7. FW 8.1.1 solved the disconnect problem for one of them but the last SOHO has been a persistent problem. I tried everything including resetting the SOHO to factory and starting from scratch, even swapped out the modem. My problem only went away after replacing the SOHO with an ASUS.

I initially was sold on the security advantages over a consumer grade router but in the end I can spend only so much time on the problem. I have contacted the seller; they referred me back to Peplink. I understand I can open a support ticket, but it is out of warranty and I wasn’t too enthusiastic about paying for support to fix a problem that began with FW 8.

I read the website which to me validates the problem FW 8 has caused with the SOHO:

I reached out to the community forum for help but I didn’t get very far with that. I really was hoping the latest FW update would fix my connectivity problem; it did for one of my SOHOs, but not this one.

2 questions if you wouldn’t mind considering:

Are you aware of any modem incompatibilities with SOHO routers? I had an ARRIS SB6190 initially; now I’m using a Motorola SB8600. The SOHO disconnects with both; the ASUS replacement is fine with either one.

Can I downgrade the SOHO to FW 7 now that I am have 8.1.1 installed? I no longer see it as an option on the router web interface.

Thank you for reaching out.

Best regards,

Older versions of the firmware are archived at



A search of the forum will reveal discussions about this issue, a couple of which I either Initiated or in which I was involved. I don’t know they these issues were ever resolved or fully explained. However, I have not seen anything recently vis-a-vis this issue.

Yes – @zegor_mjol gave you a good link to start that process.

Assuming your vendor (“Partner”) can’t help … just do it. :neutral_face: Not speaking for Peplink … but … Peplink does not “officially” ofer much support for out-of-warranty hardware. However, Peplink is a company with a conscience and has demonstrated serious interest in resolving issues with their firmware. If what you are experiencing turns out to be a hardware issue and you are out of warranty that’s a problem. But sometimes tickets illuminate “edge cases” and the engineers use these issues to improve the product. And, special builds of FW are often the result. (Don’t try this with Cisco, Netgear, TP-Link or the myriad of unnamed, anonymous Chi-Com manufacturers. They won’t give you the time of day.) Start here.

You never lose the ability to downgrade to firmware 7. You can always download the firmware to a computer from the Peplink website (link above) and do a manual install from the computer while logged into the router. I too, wanted to keep firmware 7 for a long long time and blogged about it
A nifty router firmware trick

Interesting that the Asus router works better. Do you know if its running on the same Wi-Fi channels in each frequency band. Signal strength for WiFi is always the first subject, did you note the signal strength of the devices connected to the problematic Surf SOHO? Also, positioning can make a big difference, is the new Asus in the same spot as the problematic SOHO?

As for fw 8, my issues were solved with the 8.1.1 release, but my issues were not yours.

As for communication with a modem, the problems I experienced were making the initial connection. I never had an existing connection fail. One suggestion is to disable Health Checking at least when making the initial connection. Health Checking is not a big deal on the SOHO since it does not do multiple Internet connections concurrently.