Surf SOHO Mk3 - VLAN Routing Switch

Hello there,

I am new here as I am a proud owner of a Surf SOHO Mk3.
Unfortunately I ran into a dead end setting up my network so I am hoping the community can help me.

I am trying to setup multiple VLANs on a managed Switch (Netgear GS308T) connected to the Soho Mk3.
What I did:

Soho Mk3:
Setup Vlans 2,3,4,5 with their gateways (eg. 10.10.20.x, GW:
Static IP for switch in untagged LAN

Netgear Switch:
Defined a Static IP with the gateway of the router
Setup same Vlans 2,3,4,5 (same vlan ID and PVID)
Assigned the switch ports to the vlans.

Vlan2,3,4,5: Port 1 (Tagged/Trunk Port)
vlan2: Port 1(tagged), Port 2,3,4 (untagged/access)
vlan3: Port 1(tagged), Port 5 (untagged/access)
vlan4: Port 1(tagged), Port 6 (untagged/access)
vlan5: Port 1(tagged), Port 7 (untagged/access)
Port 8: unassigned/dead

Soho Port 4 (Trunk, Any Vlan) connected to Switch Port 1 (tagged)

If I connect a Laptop to any of the Vlan Ports of the switch, I get the dedicated IP address assigned (10.10.20.X, 10.10.30.X, etc.) but I get no internet connection and I cannot ping the switch IP or the router gateway.

The Switch is not capable to route on its own. My best guess is, that the routing has an issue so my question:
How do I define the routing on the SOHO so that the switch knows that it should route all traffic through switch port 1 to the router port 4 and then to the WAN.

Your help is much appreciated!
Thank you,

Welcome to the Peplink Community! SOHO Port 4 is a trunk port allowing tagged or untagged packets. VLANs 2,3,4,5 are configured in the switch but does it pass untagged packets OK?

When you cannot ping the switch IP address, does that mean both the tagged and untagged IP? If the laptop can ping the tagged IP of the switch, does it work if the switch points to a tagged VLAN IP of the SOHO instead?

1 Like

Please try this firmware here.

1 Like

I managed to get an internet connectionthrough my vlans on the switch. It was an configuration error on the switch.

But now there is another issue. I activated the inter vlan routing on my default lan and the inter-vlan routing on the vlan.
I do not get a connection to the device on the vlan. Are there any configurations I missed to communicate/access devices on a vlan from the default lan?

If the device on the VLAN is getting out the internet it must be pointing to the SOHO for a default gateway. Is it possible an internal firewall rule on the SOHO could be blocking this? Does the device respond to pings from the SOHO router?

1 Like

After setting up the internal firewall rules the communication worked.
Thank you for the help and support!