Surf SOHO MK3 poor wifi speed and external antennas question


#1

Hello everybody!

I’m a new user of this router, but even if I’m satisfied with all the features it offers, I’m having a problem after an update of my internet connection speed. I’m now at 90 Mb/s from my previous 18 Mb/s. I’ve always downloaded at 1.8 MB/s from my laptop (wifi connected), but now I’m stuck at that speed or little more !

If I use a cable to connect my laptop to the SOHO I get full speed and I get full speed even if I use the wifi of my ISP router! I

tried to do a factory reset, but nothing has changed. I’m using 2.4 Ghz band only (as the ISP router does) and the transmitting channel is free (I used a wifi analyser, but there are not many wifi networks around). WAN is the only gateway configured (no Wifi WANs); the signal is at -38 Db (optimal I would say) and I attached the 3 external antennas shipped with the router.

BTW How I can be sure the SOHO is using external antennas and not the internal one ? I couldn’t find any indication on the web admin.

Thank you in advance for any help :slight_smile:
Maurizio


#2

If you look under the AP—>Settings there is an “Internal/External Antenna” setting with radio buttons. You can pick.

To be honest, SOHO WiFi performance is pretty poor. Even with external antenna. I’ve resolved to using a dedicated Ubiquiti access point if I need any real WiFi from these devices. For a simple use (maybe 1 or 2 devices for testing purposes) they are fine but nothing more. Pepwave sells several APs of their own but they get pretty poor reviews and I’m well versed with Ubiquiti stuff so I prefer those and just love their management stuff. Just some ideas. You may try a different external antenna (maybe a higher dB gain pair) but realistically you aren’t going to get very great WiFi performance on these particular routers themselves.


#3

OK thanks for sharing your experience.
Before going out and grab a new access point I would be sure that the external antennas are used. Unfortunately my AP/Setting page doesn’t have any radio regarding antennas !

here’s a screenshot

The Status/Device page states :

Model
Pepwave Surf SOHO MK3
Product Code
SUS-SOHO
Hardware Revision
1
Firmware
7.1.0 build 1284

Thank you again
Maurizio


#4

I’m sorry - you are using the newest MK3 - it does NOT have any internal antennas! So you are always using the external antennas. Mine are old HW1 model which do have the internal and I of course have that option to switch between the internal and external (if attached) antennas.


#5

@mamaffei

Do you compare and test before 5Ghz WIFI performance ? Beside that, can you share the WIFI analyzer report here ?


#6

Yes, I tried some hours ago and I get full speed with one client only : 9 MB/s

I will share the wifi graph this evening (in Europe) and I will try to do some more tests on 2.4 Ghz band. If the router has the potential to serve data at that speed maybe we can find a way to fix the problem : the first test I want to do is to force the wifi channel on Surf once I got the one used by the previous router


#7

Here’s the report at 2.4 Ghz and 5 Ghz The networks with erased name are mine. Later I’ll try to force the 2.4Ghz net on an different channel.

I used Wifi Analyser for Android. The phone was near the antennas of my PC and the transmit power of the Surf is set to low. I’ve already tried to maximize it, but the throughput doesn’t change


Maurizio


#8

Please open a support ticket for support team to check from the device.

https://contact.peplink.com/secure/create-support-ticket.html


#9

I had great WiFi speed running firmware 7.0.3 build 1260.

I recently upgraded the firmware to 7.1.0 build 1284 and WiFi speeds dropped by 50%. At first I thought it was an ISP issue, but Ethernet speeds were unaffected.

I have just reverted to firmware 7.0.3 and the WiFi speeds are back to their former status.

Try downgrading the firmware and see if that helps.

Note to mods: should I raise a support ticket?


#10

This shouldn’t relate to the firmware upgrade. Try to do Wifi survey at your environment to avoid the interfered channel.


#11

I have a Pepwave SURF SOHO MK3 router and was also getting poor WiFi coverage via its external antennas. Hooked up a Ubiquiti Unifi AC LR access point, got improved WiFi range but still unable to get the coverage at the master bedroom that is furthest away from the AP. Also the Unifi AC LR access point is in a disconnected status when I tried to administer it via the Unifi Controller. Not sure if this is due to my router settings but its one problem after another for me. Understand this is not the right forum to discuss Unifi product issues but hopefully this can help mamaffei.


#12

I am running only one SSID:-
2.4MHz on channel 1, & 5MHz on auto (currently channel 36).
Using Apple Airport Utility on an iPad I can detect no other WiFi signal, so no conflicts.


#13

Make sure you are on the same layer-2 with the controller and the AP. This is a common problem folks have. Might be your issue. For example, don’t have the AP on an isolated VLAN and your controller on a separate (also isolated) VLAN or the 2 cannot see and communicate with each other.