Surf SOHO MK3 locks up around 60-90 days

Every since I purchased the Surf SOHO it seems to lockup every 60-90 days. I would be more precise if I had a way to capture the lock ups but the event log does not seem to do that. it just happened again over the July 19-22 period when we were out of town. How did I know? My Arlo cameras and security cameras were offline. Sadly I was 4 hours away.

Here is what I know.
hardware revision 1
firmware 7.1.0 build 1284
pepvpn version 7.0.0

it is connected to an Arris SB6190 which says it has been up 12d:23h:17m
it is at hardware version 3
software version 9.1.103AA40

Usually when this happened in the past and I was out of town I had a relative come over, pull the plug on the SOHO, then put it back in and it would be up in running in no time. Since its purchase, approx Dec 2017, it has locked up 4 times. July 2018, May, 2018, March 2018 and January 2018.

I am not running a VPN.
I have 4 WiFi networks 3 of which are VLANs
I have the cable modem connected to the WAN port
I have my Mac occasionally connected to a LAN port to access the router admin page.
I have my Arlo cameras connected to another LAN port.
I do not have remote access enabled.

I am not doing any port forwarding.

If there is something I can do to help diagnose the problem please tell me.
I do not know when the event will happen.

The last time I observed it was July 22. I was suspicious because I had not gotten any text messages from my Arlo cameras concerning motion, which never happens. I had just gotten home from being out of town for 3 days. I noticed when walking in the house I had no WiFi on my iPhone, the cameras were offline and the two lights on the Surf SOHO were on steady and not blinking. The cable modem was on with all status lights ok. The Arlo station, connected to the LAN port, indicated it was not connected to the WAN.

I cycled power on the SOHO, waited a few minutes, the WiFi networks came up and the Arlo base station went green indicating it could connect to the WAN, and the cameras came on line.

I would like to get this resolved. Let me know how I can help.


bob H

It is very unlikely the router is locking up. When it happens you should logon to the router from your LAN and see what the WAN status is. Also, set yourself up with InControl2 as it has a log of the up and downtime of the router.

Most likely the problem is the handshake between the router and the cable modem. This has been a long onging issue with Peplink routers and some cable modems. For example see this

You can also go into the cable modem and look at its log to see when it goes off line and online. This will likely confirm the problem is not the router itself failing but the communication between the router and modem failing after the modem has gone offline.

One solution is to set the WAN definition to always use full duplex and always run a gigabit speeds and thus avoid the problematical handshaking. It worked for me once, cant promise it will work for you. The article has other ideas too.

1 Like


@Michael234 is right. When the issue happen, do you able to login to the SOHO router via Ethernet LAN ? If yes, please obtain a diagnostic report from the device and send for support team to check.

1 Like

That is what I tried to do when the event happened. I have a permanently connected line cord from LAN port 4 that I used to connect to the router for admin work. When the WiFi network went off line I hooked my Mac to it and was unable to connect to the admin portal. There was not response from the router. I could not get logged into the admin page, The lights were frozen and so was it. The only way to connect was to cycle power to the router. the cable model was up and functioning properly.

I have gone in and manually set the WAN port to full duplex and 1Gbs. Will see if that has an effect over time.

This work around has not eliminated the problem. I have opened a support ticket via the 3G Store which is where I purchased the router.