Surf Soho MK3 Internet Connectivity Problem After Firmware Upgrade

Greetings! New community member here.

I have 3 Surf Soho MK3 Routers purchased between 5/2018 and 4/2019. They are in 3 different environments and operate independently.

The first unit purchased 5/2018 and the second unit purchased 8/2018 both have had connectivity problems since upgrading to version 8 (8.0.1, 8.1.1) firmware. They are currently on version 8.1.1 and cannot maintain an internet connection without having to be reset regularly. The most recently purchased Surf Soho (4/2019) has not had the same issues and has been able to hold an internet connection throughout all firmware upgrades. It is currently running 8.1.1 without any problem.

I am frustrated because this issue did not surface until the version 8 firmware. One of the routers is several hours away by car and I rely on it for video surveillance.

I labored to achieve the 8.0.1 upgrade with these 2 routers; once it finally installed, the connectivity problems started immediately. I subsequently had to downgrade to version 7 to correct the problem on both. When version 8.1.1 came out, I was eagerly hoping it would address this problem. The upgrade to 8.1.1 itself proceeded without a problem (unlike version 8.0.1), but sadly the loss of internet connectivity has persisted. Is this a known problem? Any thoughts would be appreciated. Thank you.

I completely wiped my Surf Soho Mk3 router to make sure I got rid of everything related to that firmware roll out as a last resort by factory resetting it.

I then manually uploaded the 8.1.0 FW image (that was the newest one at the time), and did not use InControl to do this, and I did not download the update through the router either. Connected to the router via ethernet cable.

After that all and some other details that you’ll see his post below, all of my problems went away and today it’s working just as well as it did when I got it three years ago.

Thank you Datahead. I’ve always connected directly to the router and have done the factory reset also but have mostly used the router firmware update tool. I will try downloading the firmware file and then install manually. Appreciate the link to the other discussion! Best regards

One guess: perhaps something about the WAN definition changed between firmware 7 and 8?
Another guess: perhaps Health checks are failing but the network is, in fact, functional.

Could you copy/paste the Event Log messages here.
What modem(s) are the routers connected to?
Speaking of modems, have you tried logging in to the modems to see if there are any errors there? IP address 192.168.100.1 may get you into the modem.

Thank you Michael. I am using a Motorola model MB8600 DOCSIS 3.1 cable modem for all 3 Surf Soho routers I own. The 3 routers are in separate environments.

All 3 routers were purchased over the course of about a year 2018-2019. The most recently purchased Surf (router #3) has had no issues with any firmware from 7 thru 8. The other two have had problems after updating to 8, one more than the other.

After upgrading to FW 8.1.1, The Surf in my home (router #1) held an internet connection for several days before needing to be reset. Since then, it required another reset after several days to a week, and has now held the internet connection for a week after the 2nd reset. This is much better than its behavior under the preceding FW8 version. (With the previous FW 8 version, router 1 did not hold an internet connection at all and had to be downgraded to the preceding FW 7 version). I checked the event log for the modem attached to this router today but the events of the date in question are no longer in the log.

Surf #2 is remote, and initially seemed to be working after upgrading to FW 8.1.1. Certainly the install was less of an ordeal. Within a day, however, it dropped the internet connection and has been down since. With the preceding FW 8 version, it would not hold an internet connection at all (just like router 1 and had to be downgraded to the preceding FW 7 version). I will be able to check on this router again in a week or so and hopefully will have captured the event in the log. If so, I will certainly post.

Thank you for your time and suggestions. It’s a perplexing issue given the differing behaviors of the same model routers attached to the same model modems.

Best regards

Are health checks failing?

Are there any messages in the Router Event log when things go bad?

What are the status lights in the modem when things go bad?

Are the routers configured with a reasonable estimate of the real up/down speed?
Is the coaxial cable screwed in tightly? Don’t ask me where this suggestion came from :frowning:

When things go bad, you want to power cycle the modem too. Again, the voice of experience here.

Cable modems have an event log, yes, but they should also report on transmission errors. You will need to get in the habit of logging into the modem and seeing how many correctable and uncorrectable transmission errors there are. Its a pain.

Your routers can do the same thing. There is a support.cgi page that reports on Ethernet transmission errors.

If you use InControl2, you should be able to see a log of when each router was online and offline. This may show a pattern over time.

And, its a good idea to have both the router and the modem plugged into a surge protector, at the least. My modem is plugged into a line interactive UPS. Not cheap, but like buying insurance. For me, replacing the modem is a bigger hassle than replacing the router.

Good luck.
Michael (forced to use a new id)

I wrote a long response that got held up as spam when my Forum ID changed. Hopefully they will release it. If not, I’ll try my best to re-do it…

@Michael234, you post has been released.

Thank you for the thoughtful post. I had the opportunity to check into my remote router #2 and its attached modem. I first re-established my internet connection by unplugging and then restarting my router. I had an internet connection for about 24 hours before it went out again. I checked the logs for both before and after and attached below:

Router event log before new outage:

The forum will only allow one attachment at a time so I’ll add additional posts with the before and after logs.

After the new outage, the modem log did not document any additional events but I am concerned about the frequent “No Ranging Response received-T3 time-out” events. I have contacted my ISP who wants to send out a tech.

Best regards

Router event log after new outage:

Modem log was the same before and after the new internet connection drop; no new events were recorded (the last recorded event date was Feb17; I grabbed the screen on Feb 21):

When the new outage occurred, I re established my internet by unplugging the router, not the modem.

I am still concerned about the “No Ranging Response received-T3 time-out” events for the modem but at least with this most recent outage, the modem did not throw the same error (or any errors)

Best regards