Surf SOHO MK3 and Max Adapter 5G

I have a ticket opened. 21070300

I’ve worked through 5GStore and they have requested help from Peplink.

No response since 1:00pm CST Friday. Hoping to get some help here.

When the Max Adapter is plugged into the Surf it recognizes the device but just cycles between initializing and connecting. I updated the firmware on the Surf to 8.1.2 and that increased the awareness of the Surf. Meaning the Surf now reports signal strength with bars and shows “LTE”.
The “Details” button also now shows the name of the device and the network info from the SIM.
Still cycling…
I noticed there was a beta firmware released. 8.1.3, so I tried upgrading to that but no change in results.

I should note the Max Adapter 5G connects fine connecting directly to the laptop via USB.

I should add some troubleshooting that has already been attempted.

Both Auto and Custom APN.

Under custom, tried broadband, BROADBAND, and ATT.

When connecting through the laptop and viewing details, it is connecting with BROADBAND

May I know what is the firmware version of your MAX Adapter 5G? Is it a special firmware? If not, try upgrade MAX adapter with this firmware to confirm it helps -

how do I upgrade the firmware? the manual does not cover the steps.

firmware is base version delivered with the product. It is not a special version.

I don’t have access to the device right now. I will update this post in the morning with version.

@ronnieb21, Oops! Looks like we were sharing a non-SOHO firmware. Let us check on it and come back to you.

is your plan with ATT activated with the IMEI of the modem?

Modem works fine when connected to my PC.

I don’t know cellular, so I’m not sure if that answers your question.

I see the topic is 6 months old, but I am having this exact problem and I am wondering if there was a resolution.
For further clarity, I have recently purchased the Max Adapter 5G and Surf SoHo Mk3. The Max Adapter is able to connect when I use it on a PC, so I know it works and has valid cell service. I have loaded the latest firmware (8.1.3) on the Surf and have also tried the latest Beta (8.2.0), but the Max Adapter just cycles through initializing and connecting states and never actually connects.

@David_Pearson, you may refer to the supported model for MAX Adapter below.

So… it isn’t compatible. Not the answer I was hoping for, but at least I understand why it isn’t working. In case anyone else is trying to make this mistake, the FAQ document for the Max Adapter indicates that it works with “all Peplink devices which have a USB port…”. Might want to fix the document.

Thank you for bringing our attention to some details, that need addressing.
We have made some changes to the MAX Adapter FAQ.