Surf Soho Load Balancing

I have a Surf Soho that primarily connects to two public wifi networks (2.4GHz and 5GHz). Service can be spotty sometimes, and bandwidth is throttled to 5Mbps for each. I have attached an Inseego Mifi2000 5G hotspot via USB. I only want the hotspot to be used during times of peak demand, such as video calls, and preferably without relying entirely on the hotspot. What is the right load balancing method to use (I have tried weighted Balance and Priority)? Do all three connections need to be in Priority 1?

Hi John. Welcome to the forum! :<)

The SOHO is a great router but I think you have a bit of a mis-match between it and what you want to accomplish. The SOHO is a “one WAN at a time box.” The Balance and MAX series are excellent at the mission you describe. The SOHO can do fail-over but not balancing.

1 Like

Would a Speedfusion cloud license provide additional benefits here?

If so, I guess that opens up possibilities with wan smoothing or fec for better VoIP/video calls. But would use more data.

Otherwise hot failover to your mifi in case your main goes down. Haven’t looked into weighted balance yet.

I’m just getting started wit Speedfusion myself. :sunglasses:

1 Like

Yes, certainly @stego – good point. If @johnstevens wants to go that route it should work fine – as explained here:
SpeedFusion Cloud and soho MK3 and SpeedFusion Cloud questions - #2 by MartinLangmaid.


Excellent, I do have SpeedFusion Cloud and will give that a try and report back.

I removed existing outbound policies to prevent interference with the SpeedFusion settings. Set WAN Smoothing to Max/High and Forward Error Correction to High. Receive buffer zero(I initially tried Receive Buffer=100 but that may have been a mistake). Prioritized the connections, with the hotspot in the #3 position. I’m connecting an individual client through this configuration. Initial results on a video call last night were not great but I’m going to observe it again this morning as I work. Last night I stumbled upon a SpeedFusion monitoring screen that showed how bandwidth for a SFCloud connection was being shared among the connections. This morning I can’t find it!

Its in Status > Speedfusion to the right of th profile there is a graph button image

Thanks Martin! SpeedFusion doesn’t appear on my Status page, but I found it under Status > PepVPN.

1 Like

Maybe use one or the other but not both? Don’t think you need both WAN smoothing AND FEC. From what I read, FEC is a milder form of WAN smoothing for the bandwidth challenged. Not sure if having FEC enabled on top of WAN smoothing will yield additional benefits.

From the Speedfusion best practices guide:

But I’ll experts weigh in. :sunglasses:

I’ll just mention that setting both FEC and smoothing to “high” from the outset is probably not the best idea. I’d start with both parameters either off or “low,” increase incrementally, then stop when you achieve the desired results.

FWIW, we clients who use radio equipment behind routers with SF Cloud enabled and we generally set the buffers at about 25ms +/- as a starting point. Other folks are likely to have different experiences.

I’m back after a week of tweaking and still experiencing the same issues. I’ve locked onto a higher-bandwidth low latency (25Mbps, 25ms) public network for my 5GHz (1st priority), and paired it in a SpeedFusion Cloud with my 5G hotspot (2nd priority). I stopped FEC, set Receive Buffer to 25ms and started with WAN smoothing Normal/Normal, then progressed to Medium/Medium. During video conferences I’m still getting 10-second drops. On the 5GHz connection, I have Timeout at 1 second, Health check at 5 seconds, 1 HC retry, 1 Recovery Retry. The hotspot is in “Remain Connected” standby state. It still never rolls over from the 5GHz to the 5G when the connection drops.

Should I go to WAN Smoothing High/High? Or another combination?
Should I disable health checks on the Wifi connection?

So the chatter has died down here, but I seem to have nudged myself into a sweet spot and thought I would document the settings for others who may be trying to accomplish the same thing.

SpeedFusion Cloud

  • I am using SpeedFusion cloud for the connection where I need best bandwidth for videoconferencing.
  • WAN Smoothing is set to Medium/Medium
  • Forward Error Correction is Off
  • Receive buffer is 25ms
  • Primary wifi-based WAN is 1st priority
  • Backup 5G-based WAN is 2nd priority

Outbound Policy

  • Algorithm: Weighted Balance
  • Primary Wifi-based WAN is 9
  • Backup 5G-based WAN is 10

The change in outbound policy seems to have been the key, though it seems counter-intuitive against the SpeedFusion connection priorities. With the wifi-based WAN set to highest priority, I wasn’t getting any 5G usage at all. Three days ago I nudged the 5G weighting just ahead of the wifi WAN, and now I’m getting about 15-20% of my throughput via the 5G WAN. My total monthly usage is about 200-300GB, and I have a 100GB 5G plan, so that gives me some additional room to play with, and I will notch the wifi WAN weight down in a few days and observe whether it changes the share of bandwidth routed through 5G.

Of course I’d be interested to hear the thoughts of the engineers who know the Surf Soho product thoroughly.