Surf SOHO - connecting wifi client causes WAN failure

I have two Surf SOHO MK3s running 8.3.0, both exhibiting the same bug.

Most of the time I run with the AP disabled. I have one SSID, on a VLAN. The last time I needed to use the AP, as soon as a client connected to the SSID, the WAN went down for all clients. To get the WAN working again I either need to reboot the device, or disable and then re-enable the WAN.

There is no indication on the management portal or the Event Log that there’s any problem. The WAN shows green in the dashboard. However, if I try applying additional changes (probably anywhere in the management portal), the WAN starts displaying “Checking connectivity” indefinitely until I reboot or refresh the WAN.

If I change the SSID to be on the Private network rather than a VLAN, this problem disappears.

I suspect this problem arose after a firmware update, although since I only need the AP occasionally, I can’t be sure about that.

Another (perhaps unrelated) oddity is that when I Apply Changes to my SSID it says “Applying changes…” indefinitely (even when the AP is disabled and the WAN is working). The changes are being correctly applied, however.

Any ideas?

Well, don’t everyone shout at once! :slight_smile:

I may have some progress to report. My simple configuration was:

  1. Three wired clients all on my primary (untagged) network
  2. A separate VLAN just for wireless clients, configured with a single SSID
  3. All four LAN ports set to Access mode on my primary network

Whenever a client would connect to the wifi, the Peplink’s WAN would crash and wouldn’t recover until I rebooted or disabled and re-enabled the WAN.

What seems (strangely) to have worked is to change the settings on the one unused LAN port from Access mode to Trunk mode, with all VLANs allowed. After making that change, I’ve been able to connect to Wifi without a problem.

My testing has been limited so far. I also may have scrambled the order of the three wired LAN clients, so perhaps that had something to do with it as well. In any event, this behavior is quite strange.

have similar symptoms every now and then. I suspect routing table issues which I have yet to validate. I’m getting prepared again to jump into the ssh service prompt and exploitnl and the CVE to get to the bottom of it.

The wifi has its own VLAN which I also use for a few other devices which need to preferably be in the same subnet (think chromecast). Other LAN ports are either for that particular VLAN and one is a trunk. Every now and then, usually on reboot, i can ping the upstream router using any connection -except- the one for the streaming VLAN. No uplink whatsoever. Other times It Just Works. I suspect the routing table so much…