Stuck on Obtaining IP Address... BUT works at Verizon Store

Update - our Max Transit Cat-18 was the problem - don’t know why - we are sending the unit back to our distributor. We received a new unit yesterday and were able to get everything to work, very easily, with the AT&T and Verizon sim cards we had in the old (broken) unit.

For what it’s worth, the AT&T folks said our cards were 5G compatible and that is all they sell now. Good news that these 5G SIMs will work with Max Transit devices.

Original post:

We have a new Max Transit Cat-18 router. We have one SIM for Verizon and no other ones to try to test with. Cannot get past “Obtaining IP Address…” UNLESS we go to Verizon store - when we did that, the router worked perfectly! We have made no changes to settings after factory resets (except password, of course). Since the device worked at Verizon, does anyone know if SIM cards can be blocked for use in PepLink products? (but allowed to work at Verizon’s store)

RSSI is around -70dBm at our house and 3 or 4 bars. We have driven around our neighborhood to spot with 5 bars and around -58dBm and it still failed.

We have been on tech support calls with Verizon who even called into someone at PepLink and the result of that call is that they said we need to have a Business account for things to work. This was before we saw the device work at the Verizon store. Anyone ever hear of a business account restriction?

You said it worked at the verizon store? In what device?
What plan do you have , is it a plan that can work in routers or peplink devices?

Thank You for the reply, @Jonathan_Pitts . We took the Max Transit Cat-18 to the Verizon store and saw it work with the SIM card we had purchased. Card is supposed to work in LTE routers, at least that is what we clearly tried to explain that we needed. So all of our testing has been with same SIM, same router… worked at Verizon store but not at our home location, nor at a location with better signal strength.

What kind of signal do you have with Verizon at home? Can you try a Verizon sim there in a phone or some other device to test?

Thanks for the reply, @blaczero. At home signal is about -70dBm so we drove to a place with -58dBm. Should that be strong enough?

We have 2 phones, but don’t feel comfortable swapping SIMs on our primary devices. Our tablets are not cellular devices. No jet packs.

Take it back again to the store, Id it works there , ask them to check the tower near the location you are trying to get connected. If it doesn’t work at the store ask if there is a imei restrictions or if you’ve used all your data.


This is just a sanity check (with apologies): When you cite dBm and bars - have you ascertained that you are on an LTE (not 3G) connection?


@Jonathan_Pitts, thanks. We will go back to the store and see if it still works… and ask about IMEI restrictions.

Very frustrating.

@zegor_mjol Says LTE next to where it is trying to Obtain IP Address…

Scratch that theory (it would have been too easy)…

Will be going to stores today - maybe ATT to get one of their SIMs, then to Verizon.

Current theory is that Verizon won’t do the data plan without us having a phone plan with them. Too bad the sales folks at the Verizon store, didn’t know that. Fortunately, we have two phones and may consider switching one to Verizon.

Saga continues without resolution… just more information.

Verizon SIM works at store AND nearby the store about .75 miles away as the crow flies. Start moving about a mile or more, and changes to Connecting and eventually goes back to Obtaining IP Address. Feels like the Verizon SIM was only working on one tower?

Bought an ATT SIM card and was NOT able to get that card to work at the ATT Store nor at our home location. ATT gave us a generic SIM first and then one they brand as data-only (that’s the SIM we have, now)

Both stores are in a good sized city where both ATT and Verizon work very well (when Verizon connected 3/4 mile away from store, it had best band strength RSSI of 52dBm). Our home location is OK, but not as strong - RSSI hovers around 70dBm which, from what I have read, should work.

Look in the ic2 wan quality and look at what band it was able to connect at the verizon store.
Then try to uncheck all bands except that one and see if the device connects.
Try to put it outside if it doesn’t connect.
Then if that still doesn’t work.
If you can temporarily get a second connection via wifi-as-wan and tethered to your cell phone, you can open a support ticket and have peplink look at it.


I would probably assume that the Verizon store is sending out its own local cellular signal. I was at the store last week and my phone was in 5G, but anywhere further than the parking lot I was in LTE.

There are restrictions within the Verizon business account environment that require specific verbal confirmation to change what the type device can be used with said line. Is this SIM tied to a business account, and/or was it ever swapped into an actual phone?

@Cable17, SIMs were all purchased for only router use - not for phones.

That’s my guess, too, regarding store’s cell signals.

@Jonathan_Pitts , thank you for your post… I am currently on the two bands that were listed during the connected session on Verizon near their store… if they never connect (by tomorrow morning), I will open a ticket. WIFI works, we’ve been able to do that…

Update next day: Opened ticket with PepLink.
Current configuration has only these bands selected:
Verizon 2, 4, 5, 13, 66
ATT 2, 4, 5, 12, 17, 29, 30, 66
(without specific bands, ATT card would fail on roaming. now they just fail to connect)

What plan are you trying to use, specifically?

It is possible the VZW store is broadcasting its own signal. It is possible the cell tower nearest your home is having technical issue.

Have you considered factory resetting your device or testing the SIM in another device?

I’m having the same exact issue! I’ve moved several cities and spent a lot of time on phone with Verizon. They say it’s a known issue with peplink router and to contact them which I did Wednesday and haven’t heard back. Any resolution from the ticket?

No resolution, yet. We are working with the PepLink distributor from whom we bought the unit. I will update here once we figure it all out.

Do you have both of the antennas plugged in for that cells SIM card? Like example “cell 2 main and cell 2 diversity” both screwed in? That’s what got me my IP address. Didn’t think plugging both in was a big deal. Guess so.